summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-02-17 14:37:03 +0000
committerUlrich Müller <ulm@gentoo.org>2009-02-17 14:37:03 +0000
commit2bf950541b522e71bcf76cac91981d1331513875 (patch)
treed8192f1b0632cb1e5c8574add312b809be5cfdde /app-editors/joe
parentDrop KDE 4.1.4 (diff)
downloadgentoo-2-2bf950541b522e71bcf76cac91981d1331513875.tar.gz
gentoo-2-2bf950541b522e71bcf76cac91981d1331513875.tar.bz2
gentoo-2-2bf950541b522e71bcf76cac91981d1331513875.zip
Recent x11-terms/xterm ebuilds don't support the paste64 USE flag anymore. Don't fail in this case, bug 258012.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog7
-rw-r--r--app-editors/joe/joe-3.5.ebuild7
-rw-r--r--app-editors/joe/joe-3.7.ebuild5
3 files changed, 13 insertions, 6 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 37bbc0648e1e..1eed2965d29b 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/joe
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.63 2009/01/07 18:06:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.64 2009/02/17 14:37:03 ulm Exp $
+
+ 17 Feb 2009; Ulrich Mueller <ulm@gentoo.org> joe-3.5.ebuild,
+ joe-3.7.ebuild:
+ Recent x11-terms/xterm ebuilds don't support the paste64 USE flag anymore.
+ Don't fail in this case, bug 258012.
07 Jan 2009; Patrick Lauer <patrick@gentoo.org> joe-3.7.ebuild:
Small fix for docs, fixes #254007
diff --git a/app-editors/joe/joe-3.5.ebuild b/app-editors/joe/joe-3.5.ebuild
index 18a94c9a2fdb..036da6aab136 100644
--- a/app-editors/joe/joe-3.5.ebuild
+++ b/app-editors/joe/joe-3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.5.ebuild,v 1.13 2008/01/26 15:51:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.5.ebuild,v 1.14 2009/02/17 14:37:03 ulm Exp $
inherit flag-o-matic eutils
@@ -17,7 +17,8 @@ DEPEND=">=sys-libs/ncurses-5.2-r2"
RDEPEND="xterm? ( >=x11-terms/xterm-215-r1 )"
pkg_setup() {
- if use xterm && ! built_with_use x11-terms/xterm paste64; then
+ if use xterm && ! built_with_use --missing true x11-terms/xterm paste64
+ then
die "For full xterm clipboard support build x11-terms/xterm with USE=paste64"
fi
}
diff --git a/app-editors/joe/joe-3.7.ebuild b/app-editors/joe/joe-3.7.ebuild
index 30ca5246e813..4f234fbc7d61 100644
--- a/app-editors/joe/joe-3.7.ebuild
+++ b/app-editors/joe/joe-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7.ebuild,v 1.2 2009/01/07 18:06:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7.ebuild,v 1.3 2009/02/17 14:37:03 ulm Exp $
inherit flag-o-matic eutils
@@ -17,7 +17,8 @@ DEPEND=">=sys-libs/ncurses-5.2-r2"
RDEPEND="xterm? ( >=x11-terms/xterm-215-r1 )"
pkg_setup() {
- if use xterm && ! built_with_use x11-terms/xterm paste64; then
+ if use xterm && ! built_with_use --missing true x11-terms/xterm paste64
+ then
die "For full xterm clipboard support build x11-terms/xterm with USE=paste64"
fi
}