summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-05-05 07:28:32 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-05-05 07:28:32 +0000
commit2edfa9d9185bb4a01aedc348e8293b6f59e4937f (patch)
tree4729d11308866bba8172e0d923c9cf11189c22d3 /app-editors/hteditor/hteditor-0.8.0-r2.ebuild
parentStable on alpha + ia64, bug 89092. (diff)
downloadgentoo-2-2edfa9d9185bb4a01aedc348e8293b6f59e4937f.tar.gz
gentoo-2-2edfa9d9185bb4a01aedc348e8293b6f59e4937f.tar.bz2
gentoo-2-2edfa9d9185bb4a01aedc348e8293b6f59e4937f.zip
New version from cvs snapshot that includes previous malloc 0 fix with some other fixes.
(Portage version: 2.0.51.21)
Diffstat (limited to 'app-editors/hteditor/hteditor-0.8.0-r2.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-0.8.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/hteditor/hteditor-0.8.0-r2.ebuild b/app-editors/hteditor/hteditor-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..d560b4195da1
--- /dev/null
+++ b/app-editors/hteditor/hteditor-0.8.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0-r2.ebuild,v 1.1 2005/05/05 07:28:32 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="editor for executable files"
+HOMEPAGE="http://hte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hte/ht-${PV}.tar.bz2
+ mirror://gentoo/hteditor-${PV}-cvsupdates.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.4
+ sys-devel/autoconf
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/ht-${PV/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/hteditor-${PV}-cvsupdates
+}
+
+src_compile() {
+ econf || die
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS KNOWNBUGS TODO README
+ dohtml doc/ht.html
+ doinfo doc/*.info
+}