summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 18:29:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 18:29:29 +0000
commit572c90438ea157cbb871bad27c1cf92342e1bf2c (patch)
treed89b1014db2e40e3f87e9e81c09c312d64a4c920 /app-editors/elvis/elvis-2.2.0-r3.ebuild
parentfixed bug 266532 and adjusted dependencies (diff)
downloadgentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.tar.gz
gentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.tar.bz2
gentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.zip
Fix building with GLIBC 2.10+ wrt #277559.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/elvis/elvis-2.2.0-r3.ebuild')
-rw-r--r--app-editors/elvis/elvis-2.2.0-r3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/elvis/elvis-2.2.0-r3.ebuild b/app-editors/elvis/elvis-2.2.0-r3.ebuild
index e3cdd0416b3e..5f779ecefed9 100644
--- a/app-editors/elvis/elvis-2.2.0-r3.ebuild
+++ b/app-editors/elvis/elvis-2.2.0-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r3.ebuild,v 1.10 2008/03/11 11:24:56 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r3.ebuild,v 1.11 2009/08/05 18:29:29 ssuominen Exp $
inherit eutils versionator
-MY_PV="$(replace_version_separator 2 '_')"
+MY_PV=$(replace_version_separator 2 '_')
DESCRIPTION="A vi/ex clone"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
@@ -23,13 +23,13 @@ DEPEND=">=sys-libs/ncurses-5.2
>=x11-libs/libXft-2.1.8.2 )
app-admin/eselect-vi"
-S="${WORKDIR}/${PN}-${MY_PV}"
+S=${WORKDIR}/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}/ft2.3-symbol-collision-fix.patch"
+ epatch "${FILESDIR}"/ft2.3-symbol-collision-fix.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
}
src_compile() {