summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-02 22:22:09 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-02 22:22:09 +0000
commitf5d8dee87da859d4357ac01ca66f0ed2af147164 (patch)
treed855779c3f348d74f07cfef6581ab2f0545f027e /app-doc
parentVersion bump (bug #290824). Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-f5d8dee87da859d4357ac01ca66f0ed2af147164.tar.gz
gentoo-2-f5d8dee87da859d4357ac01ca66f0ed2af147164.tar.bz2
gentoo-2-f5d8dee87da859d4357ac01ca66f0ed2af147164.zip
Drop qt3 support
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog9
-rw-r--r--app-doc/doxygen/doxygen-1.4.7.ebuild22
-rw-r--r--app-doc/doxygen/doxygen-1.5.4.ebuild31
-rw-r--r--app-doc/doxygen/doxygen-1.5.5.ebuild31
-rw-r--r--app-doc/doxygen/doxygen-1.5.6.ebuild31
-rw-r--r--app-doc/doxygen/doxygen-1.5.7.1.ebuild31
6 files changed, 41 insertions, 114 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 29117a30acf9..e537b07b17db 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/doxygen
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.171 2009/12/26 17:24:39 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.172 2010/01/02 22:22:09 yngwin Exp $
+
+ 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> doxygen-1.4.7.ebuild,
+ doxygen-1.5.4.ebuild, doxygen-1.5.5.ebuild, doxygen-1.5.6.ebuild,
+ doxygen-1.5.7.1.ebuild:
+ Drop qt3 support
26 Dec 2009; Peter Volkov <pva@gentoo.org> doxygen-1.4.7.ebuild,
doxygen-1.5.4.ebuild, doxygen-1.5.5.ebuild, doxygen-1.5.6.ebuild,
diff --git a/app-doc/doxygen/doxygen-1.4.7.ebuild b/app-doc/doxygen/doxygen-1.4.7.ebuild
index 6b81c9de1f77..3387907786e1 100644
--- a/app-doc/doxygen/doxygen-1.4.7.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.7.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.28 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.29 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -14,10 +14,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc qt3 latex unicode"
+IUSE="doc latex unicode"
RDEPEND=">=media-gfx/graphviz-2.6
- qt3? ( x11-libs/qt:3 )
latex? ( app-text/texlive-core
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-genericrecommended
@@ -63,16 +62,7 @@ src_compile() {
export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
- export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) || die 'configure failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -118,7 +108,7 @@ src_install() {
pkg_postinst() {
elog
- elog "The USE flags qt3, doc, and tetex will enable doxywizard, or"
+ elog "The USE flags doc, and tetex will enable "
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"
diff --git a/app-doc/doxygen/doxygen-1.5.4.ebuild b/app-doc/doxygen/doxygen-1.5.4.ebuild
index ddf1c9d3b514..cf1fd1f5e196 100644
--- a/app-doc/doxygen/doxygen-1.5.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.19 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.20 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+inherit eutils flag-o-matic toolchain-funcs fdo-mime
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -13,10 +13,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc nodot qt3 latex elibc_FreeBSD"
+IUSE="debug doc nodot latex elibc_FreeBSD"
-RDEPEND="qt3? ( x11-libs/qt:3 )
- latex? ( app-text/texlive-core
+RDEPEND="latex? ( app-text/texlive-core
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-fontsrecommended
@@ -83,17 +82,7 @@ src_compile() {
local my_conf="--prefix ${D}usr"
fi
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
- export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) \
- || die 'configure with qt3 failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -131,12 +120,6 @@ src_install() {
make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- if use qt3; then
- doicon "${FILESDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "doxywizard.png" "Application;Development"
- fi
-
dodoc INSTALL LANGUAGE.HOWTO README
# pdf and html manuals
@@ -153,7 +136,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt3, doc, and latex will enable doxywizard, or"
+ elog "The USE flags doc, and latex will enable "
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"
diff --git a/app-doc/doxygen/doxygen-1.5.5.ebuild b/app-doc/doxygen/doxygen-1.5.5.ebuild
index 0a477bebcc14..03e685a6943b 100644
--- a/app-doc/doxygen/doxygen-1.5.5.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.5.ebuild,v 1.8 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.5.ebuild,v 1.9 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+inherit eutils flag-o-matic toolchain-funcs fdo-mime
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -13,10 +13,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc nodot qt3 latex elibc_FreeBSD"
+IUSE="debug doc nodot latex elibc_FreeBSD"
-RDEPEND="qt3? ( x11-libs/qt:3 )
- latex? ( app-text/texlive-core
+RDEPEND="latex? ( app-text/texlive-core
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-fontsrecommended )
@@ -83,17 +82,7 @@ src_compile() {
my_conf="--prefix ${D}usr"
fi
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LIBRARY_PATH="${QTDIR}/$(get_libdir):${LIBRARY_PATH}"
- export LD_LIBRARY_PATH="${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}"
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) \
- || die 'configure with qt3 failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -131,12 +120,6 @@ src_install() {
make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- if use qt3; then
- doicon "${FILESDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "doxywizard.png" "Application;Development"
- fi
-
dodoc INSTALL LANGUAGE.HOWTO README
# pdf and html manuals
@@ -153,7 +136,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt3, doc, and latex will enable doxywizard, or"
+ elog "The USE flags doc, and latex will enable "
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"
diff --git a/app-doc/doxygen/doxygen-1.5.6.ebuild b/app-doc/doxygen/doxygen-1.5.6.ebuild
index 8ac931e6ea10..4ed1bfcf3653 100644
--- a/app-doc/doxygen/doxygen-1.5.6.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.6.ebuild,v 1.4 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.6.ebuild,v 1.5 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+inherit eutils flag-o-matic toolchain-funcs fdo-mime
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -13,10 +13,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc nodot qt3 latex elibc_FreeBSD"
+IUSE="debug doc nodot latex elibc_FreeBSD"
-RDEPEND="qt3? ( x11-libs/qt:3 )
- latex? ( app-text/texlive-core
+RDEPEND="latex? ( app-text/texlive-core
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-fontsrecommended )
@@ -83,17 +82,7 @@ src_compile() {
my_conf="--prefix ${D}usr"
fi
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LIBRARY_PATH="${QTDIR}/$(get_libdir):${LIBRARY_PATH}"
- export LD_LIBRARY_PATH="${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}"
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) \
- || die 'configure with qt3 failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -131,12 +120,6 @@ src_install() {
make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- if use qt3; then
- doicon "${FILESDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "doxywizard.png" "Application;Development"
- fi
-
dodoc INSTALL LANGUAGE.HOWTO README
# pdf and html manuals
@@ -153,7 +136,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt3, doc, and latex will enable doxywizard, or"
+ elog "The USE flags doc, and latex will enable "
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"
diff --git a/app-doc/doxygen/doxygen-1.5.7.1.ebuild b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
index 61f13caf6c68..e0cb88516f90 100644
--- a/app-doc/doxygen/doxygen-1.5.7.1.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.5 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.6 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+inherit eutils flag-o-matic toolchain-funcs fdo-mime
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -13,10 +13,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc nodot qt3 latex elibc_FreeBSD"
+IUSE="debug doc nodot latex elibc_FreeBSD"
-RDEPEND="qt3? ( x11-libs/qt:3 )
- latex? ( app-text/texlive-core
+RDEPEND="latex? ( app-text/texlive-core
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexrecommended
@@ -90,17 +89,7 @@ src_compile() {
my_conf="--prefix /usr"
fi
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LIBRARY_PATH="${QTDIR}/$(get_libdir):${LIBRARY_PATH}"
- export LD_LIBRARY_PATH="${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}"
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) \
- || die 'configure with qt3 failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -138,12 +127,6 @@ src_install() {
make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- if use qt3; then
- doicon "${FILESDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "doxywizard.png" "Application;Development"
- fi
-
dodoc INSTALL LANGUAGE.HOWTO README
# pdf and html manuals
@@ -160,7 +143,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt3, doc, and latex will enable doxywizard, or"
+ elog "The USE flags doc, and latex will enable"
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"