summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-05 18:09:54 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-05 18:09:54 +0000
commit7a985e22752a4f846b3d9509648df1cba923f8b8 (patch)
tree309a4561d2ca9a6ca89d4663c195d70c093c29dd /app-doc
parentstable amd64, bug 236612 (diff)
downloadgentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.tar.gz
gentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.tar.bz2
gentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.zip
Add patch to require cl extensions.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/casting-spels-emacs/ChangeLog9
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild (renamed from app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild)5
-rw-r--r--app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch11
3 files changed, 23 insertions, 2 deletions
diff --git a/app-doc/casting-spels-emacs/ChangeLog b/app-doc/casting-spels-emacs/ChangeLog
index a6216cc1ef4c..382043054eda 100644
--- a/app-doc/casting-spels-emacs/ChangeLog
+++ b/app-doc/casting-spels-emacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-doc/casting-spels-emacs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/ChangeLog,v 1.2 2008/08/11 11:15:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/ChangeLog,v 1.3 2008/09/05 18:09:53 ulm Exp $
+
+*casting-spels-emacs-19-r1 (05 Sep 2008)
+
+ 05 Sep 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/casting-spels-emacs-19-require-cl.patch,
+ -casting-spels-emacs-19.ebuild, +casting-spels-emacs-19-r1.ebuild:
+ Add patch to require cl extensions.
11 Aug 2008; Ulrich Mueller <ulm@gentoo.org>
casting-spels-emacs-19.ebuild:
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
index f29c06ff1ab5..732998668589 100644
--- a/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/casting-spels-emacs-19.ebuild,v 1.2 2008/08/11 11:15:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild,v 1.1 2008/09/05 18:09:53 ulm Exp $
inherit elisp-common eutils
@@ -22,6 +22,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
edos2unix *.txt html/*.html {lisp,test}/*.el || die "edos2unix failed"
+
+ # needs cl extensions
+ epatch "${FILESDIR}/${P}-require-cl.patch"
}
src_install() {
diff --git a/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
new file mode 100644
index 000000000000..d7743d29fbf6
--- /dev/null
+++ b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
@@ -0,0 +1,11 @@
+--- casting-spels-emacs-orig/lisp/wizard-adventure-emacs.el 2007-09-17 04:18:48.000000000 +0200
++++ casting-spels-emacs/lisp/wizard-adventure-emacs.el 2008-09-05 19:59:21.000000000 +0200
+@@ -27,6 +27,8 @@
+
+ ;;; Code in the comic not needed to play the game is commented out...
+
++(require 'cl)
++
+ (setq eval-expression-print-length nil)
+
+ (setq objects '(whiskey-bottle bucket frog chain))