summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-04-24 06:57:35 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-04-24 06:57:35 +0000
commit5e57dbbb62037a8ed47f9c6dfd42190944bede2a (patch)
tree0635d39a70a9d2802f6e8d518de54ea1dbcffb89 /app-doc/doxygen
parentstable x86, bug 175512 (diff)
downloadgentoo-2-5e57dbbb62037a8ed47f9c6dfd42190944bede2a.tar.gz
gentoo-2-5e57dbbb62037a8ed47f9c6dfd42190944bede2a.tar.bz2
gentoo-2-5e57dbbb62037a8ed47f9c6dfd42190944bede2a.zip
updated to latest upstream release
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog8
-rw-r--r--app-doc/doxygen/doxygen-1.5.2.ebuild119
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.5.23
3 files changed, 129 insertions, 1 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 900c10549600..21e35c0fe324 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.121 2007/03/12 05:23:10 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.122 2007/04/24 06:57:35 nerdboy Exp $
+
+*doxygen-1.5.2 (24 Apr 2007)
+
+ 24 Apr 2007; Steve Arnold <nerdboy@gentoo.org> +doxygen-1.5.2.ebuild:
+ updated to latest upstream release, and removed unicode USE flag (russian
+ patch incorporate dupstream). Closes bug #174831.
12 Mar 2007; Steve Arnold <nerdboy@gentoo.org> doxygen-1.4.7.ebuild,
doxygen-1.5.1.ebuild:
diff --git a/app-doc/doxygen/doxygen-1.5.2.ebuild b/app-doc/doxygen/doxygen-1.5.2.ebuild
new file mode 100644
index 000000000000..2a1338fbd3e0
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.5.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.2.ebuild,v 1.1 2007/04/24 06:57:35 nerdboy Exp $
+
+inherit eutils flag-o-matic toolchain-funcs qt3
+
+DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc qt3 tetex"
+
+RDEPEND=">=media-gfx/graphviz-2.6
+ qt3? ( $(qt_min_version 3.3) )
+ tetex? ( virtual/tetex )
+ virtual/ghostscript"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+EPATCH_SUFFIX="patch"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf
+
+ # Consolidate patches, apply FreeBSD configure patch, codepage patch,
+ # qtools stuff, and patches for bugs 129142, 121770, and 129560.
+ epatch ${FILESDIR}/${PN}-1.5-legacy-patches.diff
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ epause 6
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_compile() {
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+ # set ./configure options (prefix, Qt based wizard, docdir)
+ local my_conf="--prefix ${D}usr"
+ if use qt3; then
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt3 doxywizard) \
+ || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
+ fi
+
+ # and compile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
+ LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if use tetex; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make html docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use tetex; then
+ doins latex/doxygen_manual.pdf
+ fi
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "The USE flags qt, doc, and tetex will enable doxywizard, or"
+ elog "the html and pdf documentation, respectively. For examples"
+ elog "and other goodies, see the source tarball. For some example"
+ elog "output, run doxygen on the doxygen source using the Doxyfile"
+ elog "provided in the top-level source dir."
+ elog
+ elog "See the Doxygen homepage for additional language support tools."
+ elog
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.5.2 b/app-doc/doxygen/files/digest-doxygen-1.5.2
new file mode 100644
index 000000000000..29a4b2f95bd3
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.5.2
@@ -0,0 +1,3 @@
+MD5 f2782e5bd31a7d10b092500bf0d96ae2 doxygen-1.5.2.src.tar.gz 3599976
+RMD160 d30dff3a4625ceb3f31e0fd8c97e2fe3af747d42 doxygen-1.5.2.src.tar.gz 3599976
+SHA256 496220360b92de6169458b282a8faa32065f71db26d33fb9dc291178fc75381d doxygen-1.5.2.src.tar.gz 3599976