summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-19 14:04:29 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-19 14:04:29 +0000
commitd693933e151440e7b257963cdce5ccc15293243d (patch)
tree22223dfd08e8c1dc539af9b75c8a5de7f0a23456 /app-crypt
parentMigrated to EAPI 2 in order to get rid of built_with_use. (diff)
downloadgentoo-2-d693933e151440e7b257963cdce5ccc15293243d.tar.gz
gentoo-2-d693933e151440e7b257963cdce5ccc15293243d.tar.bz2
gentoo-2-d693933e151440e7b257963cdce5ccc15293243d.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
index fcdb3971e251..ffbc28c0bb9a 100644
--- a/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
+++ b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild,v 1.8 2009/07/21 16:49:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild,v 1.9 2009/08/19 14:04:29 betelgeuse Exp $
+
+EAPI="2"
inherit eutils qt4
@@ -16,28 +18,14 @@ SLOT="2"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=app-crypt/qca-${QCA_VER}
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
x11-libs/qt-core"
RDEPEND="${DEPEND}
app-crypt/gnupg"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
- echo
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while qca is built without this flag. It will not work."
- echo
- eerror "Possible solutions to this problem are:"
- eerror "a) install ${PN} without debug USE flag"
- eerror "b) re-emerge qca with debug USE flag"
- echo
- die "can't emerge ${PN} with debug USE flag"
- fi
-}
-
-src_compile() {
+src_configure() {
# cannot use econf because of non-standard configure script
./configure \
--qtdir=/usr \
@@ -46,7 +34,6 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
- emake || die "emake failed"
}
src_install() {