summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-08-30 19:03:29 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-08-30 19:03:29 +0000
commitb438cb77460d13ad5b369e549b5c4da3e8099a99 (patch)
treed69b1f27ec5aa113daea9bd48591e7a9d955a55a /app-crypt
parentfixing #27608 (diff)
downloadgentoo-2-b438cb77460d13ad5b369e549b5c4da3e8099a99.tar.gz
gentoo-2-b438cb77460d13ad5b369e549b5c4da3e8099a99.tar.bz2
gentoo-2-b438cb77460d13ad5b369e549b5c4da3e8099a99.zip
fixing #27608
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog11
-rw-r--r--app-crypt/gnupg/Manifest4
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.3-r21
-rw-r--r--app-crypt/gnupg/gnupg-1.2.3-r2.ebuild59
4 files changed, 72 insertions, 3 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 3e845935514d..113144cac858 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.26 2003/08/26 19:54:00 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.27 2003/08/30 19:03:25 taviso Exp $
+
+*gnupg-1.2.3-r2 (30 Aug 2003)
+
+ 30 Aug 2003; Tavis Ormandy <taviso@gentoo.org> gnupg-1.2.3-r2.ebuild:
+ configure interprets libexecdir different from the install makefile
+ target, which breaks external applications (specifically hkp and mailto)
+ #27608.
+ minor syntax changes.
+ bumped.
*gnupg-1.2.3-r1 (26 Aug 2003)
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index 0309d7cca2b3..2fc85186c434 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -1,7 +1,7 @@
-MD5 2791f5b3e44a572f64171175e672caec gnupg-1.2.3-r2.ebuild 1639
+MD5 5f1e21fc7d02a593463fe79c3182b26f gnupg-1.2.3-r2.ebuild 1633
MD5 caf2a95ab1fd8d5cadf1b14752fa2838 gnupg-1.2.3.ebuild 1624
MD5 4c1ee3c28a241e7b2675ac1162b076cb gnupg-1.2.3-r1.ebuild 1700
-MD5 7ffbbf902f99b8103028111dd5113800 ChangeLog 3881
+MD5 c04ca2e67c7c00b1615c4ed3fb12dc54 ChangeLog 4176
MD5 1e79df8d1b4cfa3dd38e7b8e832db358 gnupg-1.2.2-r1.ebuild 1624
MD5 baee9407222e66ea7d35126e2352c558 gnupg-1.2.2.ebuild 1621
MD5 773ecd19392b8f793d7626c9814e1e0b files/digest-gnupg-1.2.2-r1 65
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.3-r2 b/app-crypt/gnupg/files/digest-gnupg-1.2.3-r2
new file mode 100644
index 000000000000..f63dbab6d49f
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.3-r2
@@ -0,0 +1 @@
+MD5 cdca1282d7901f9ddb52f9725b001af2 gnupg-1.2.3.tar.bz2 2294773
diff --git a/app-crypt/gnupg/gnupg-1.2.3-r2.ebuild b/app-crypt/gnupg/gnupg-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..627296bd5bf4
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.3-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.3-r2.ebuild,v 1.1 2003/08/30 19:03:25 taviso Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc"
+IUSE="X zlib ldap nls"
+
+DEPEND="dev-lang/perl
+ X? ( x11-misc/xloadimage )
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--enable-external-hkp"
+
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable X photo-viewers`"
+ myconf="${myconf} `use_with zlib included-zlib`"
+
+ # Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if ! use sparc; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf} --libexecdir=/usr/lib
+ emake
+}
+
+src_install() {
+ einstall libexecdir="${D}/usr/lib/gnupg"
+
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS \
+ README THANKS TODO VERSION doc/{FAQ,HACKING,DETAILS,ChangeLog,OpenPGP,\
+ faq.raw}
+
+ docinto sgml
+ dodoc doc/*.sgml
+
+ dohtml doc/faq.html
+
+ chmod u+s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous"
+}