summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-16 16:09:59 +0000
committerDane Smith <c1pher@gentoo.org>2011-05-16 16:09:59 +0000
commit728ebca150ec313bb43f6713e47a0e10795a2cf0 (patch)
tree6471e4f17f92d619a38ed340cd8a966f3e220a6d /app-crypt
parentDrop m68k keyword. (diff)
downloadgentoo-2-728ebca150ec313bb43f6713e47a0e10795a2cf0.tar.gz
gentoo-2-728ebca150ec313bb43f6713e47a0e10795a2cf0.tar.bz2
gentoo-2-728ebca150ec313bb43f6713e47a0e10795a2cf0.zip
app-crypt/chntpw: Version bump to 110511 wrt bug 367267.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/ChangeLog7
-rw-r--r--app-crypt/chntpw/chntpw-110511.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-crypt/chntpw/ChangeLog b/app-crypt/chntpw/ChangeLog
index 9eb0bb5d282f..6ec6f37443d0 100644
--- a/app-crypt/chntpw/ChangeLog
+++ b/app-crypt/chntpw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/chntpw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.18 2011/04/05 13:47:29 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.19 2011/05/16 16:09:59 c1pher Exp $
+
+*chntpw-110511 (16 May 2011)
+
+ 16 May 2011; Dane Smith <c1pher@gentoo.org> +chntpw-110511.ebuild:
+ Version bump to 110511 wrt bug 367267.
05 Apr 2011; Dane Smith <c1pher@gentoo.org> metadata.xml:
Updated metadata to reflect me as the new maintainer. Added to the
diff --git a/app-crypt/chntpw/chntpw-110511.ebuild b/app-crypt/chntpw/chntpw-110511.ebuild
new file mode 100644
index 000000000000..dd62424da229
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-110511.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-110511.ebuild,v 1.1 2011/05/16 16:09:59 c1pher Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' \
+ Makefile || die
+
+ emake clean || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto" || die
+}
+
+src_install() {
+ dobin chntpw cpnt reged || die
+
+ if use static; then
+ dobin {chntpw,reged}.static || die
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt || die
+}