summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-16 07:18:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-16 07:18:57 +0000
commit63059050a9e34328f8dfcee3d681aedb260878a5 (patch)
treed082055baa8ffb9aebd1b796aeb7895f9d723444 /app-crypt
parentVersion bump. (diff)
downloadgentoo-2-63059050a9e34328f8dfcee3d681aedb260878a5.tar.gz
gentoo-2-63059050a9e34328f8dfcee3d681aedb260878a5.tar.bz2
gentoo-2-63059050a9e34328f8dfcee3d681aedb260878a5.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/trousers/ChangeLog7
-rw-r--r--app-crypt/trousers/trousers-0.3.10.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/app-crypt/trousers/ChangeLog b/app-crypt/trousers/ChangeLog
index 3c36a631fd51..3b19d9bf1225 100644
--- a/app-crypt/trousers/ChangeLog
+++ b/app-crypt/trousers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/trousers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.36 2012/09/10 23:00:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.37 2012/11/16 07:18:57 patrick Exp $
+
+*trousers-0.3.10 (16 Nov 2012)
+
+ 16 Nov 2012; Patrick Lauer <patrick@gentoo.org> +trousers-0.3.10.ebuild:
+ Bump
10 Sep 2012; Mike Frysinger <vapier@gentoo.org> trousers-0.3.6-r1.ebuild:
Drop -m64 hardcode.
diff --git a/app-crypt/trousers/trousers-0.3.10.ebuild b/app-crypt/trousers/trousers-0.3.10.ebuild
new file mode 100644
index 000000000000..5c18a09f5b8b
--- /dev/null
+++ b/app-crypt/trousers/trousers-0.3.10.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/trousers-0.3.10.ebuild,v 1.1 2012/11/16 07:18:57 patrick Exp $
+
+EAPI="3"
+
+inherit autotools eutils linux-info user toolchain-funcs
+
+#MY_P="${PN}-${PV%.*}-${PV##*.}"
+
+DESCRIPTION="An open-source TCG Software Stack (TSS) v1.1 implementation"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc" # gtk
+
+# gtk support presently does NOT compile.
+# gtk? ( >=x11-libs/gtk+-2 )
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/openssl-0.9.7:0"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# S="${WORKDIR}/${P}git"
+
+pkg_setup() {
+ # Check for driver (not sure it can be an rdep, because ot depends on the
+ # version of virtual/linux-sources... Is that supported by portage?)
+ linux-info_pkg_setup
+ local tpm_kernel_version tpm_kernel_present tpm_module
+ kernel_is ge 2 6 12 && tpm_kernel_version="yes"
+ if linux_config_exists; then
+ linux_chkconfig_present TCG_TPM && tpm_kernel_present="yes"
+ else
+ ewarn "No kernel configuration could be found."
+ fi
+ has_version app-crypt/tpm-emulator && tpm_module="yes"
+ if [[ -n "${tpm_kernel_present}" ]]; then
+ einfo "Good, you seem to have in-kernel TPM support."
+ elif [[ -n "${tpm_module}" ]]; then
+ einfo "Good, you seem to have TPM support with the external module."
+ if [[ -n "${tpm_kernel_version}" ]]; then
+ elog
+ elog "Note that since you have a >=2.6.12 kernel, you could use"
+ elog "the in-kernel driver instead of (CONFIG_TCG_TPM)."
+ fi
+ elif [[ -n "${tpm_kernel_version}" ]]; then
+ eerror
+ eerror "To use this package, you will have to activate TPM support"
+ eerror "in your kernel configuration. That's at least CONFIG_TCG_TPM,"
+ eerror "plus probably a chip specific driver (like CONFIG_TCG_ATMEL)."
+ eerror
+ else
+ eerror
+ eerror "To use this package, you should install a TPM driver."
+ eerror "You can have the following options:"
+ eerror " - install app-crypt/tpm-emulator"
+ eerror " - switch to a >=2.6.12 kernel and compile the kernel module"
+ eerror
+ fi
+
+ # New user/group for the daemon
+ enewgroup tss
+ enewuser tss -1 -1 /var/lib/tpm tss
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.3.5-nouseradd.patch"
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -(Werror|m64)//' \
+ configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ #econf --with-gui=$(usev gtk || echo openssl) || die "econf failed"
+ econf --with-gui=openssl || die "econf failed"
+}
+
+src_install() {
+ keepdir /var/lib/tpm
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NICETOHAVES README TODO
+ use doc && dodoc doc/*
+ newinitd "${FILESDIR}/tcsd.initd" tcsd
+ newconfd "${FILESDIR}/tcsd.confd" tcsd
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ insinto "${udevdir}"/rules.d
+ doins "${FILESDIR}"/61-trousers.rules
+ fowners tss:tss /var/lib/tpm
+}
+
+pkg_postinst() {
+ elog "If you have problems starting tcsd, please check permissions and"
+ elog "ownership on /dev/tpm* and ~tss/system.data"
+}