summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-10-27 01:34:44 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-10-27 01:34:44 +0000
commit2f77123ce7e9215af437c979717aab817bdb8b3b (patch)
tree41afb7ffc0974cee919dbf979bd0f45c59611812 /app-crypt/xca/xca-0.5.1-r1.ebuild
parentFix postinstall instructions, bug #135233. (diff)
downloadgentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.tar.gz
gentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.tar.bz2
gentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.zip
Fixes db detection, thanks to Tomas Sedlak, bug#152846. Cleanup old revisions, organize patchset
(Portage version: 2.1.1)
Diffstat (limited to 'app-crypt/xca/xca-0.5.1-r1.ebuild')
-rw-r--r--app-crypt/xca/xca-0.5.1-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/app-crypt/xca/xca-0.5.1-r1.ebuild b/app-crypt/xca/xca-0.5.1-r1.ebuild
index b6dee57d2143..9ed95fba9d62 100644
--- a/app-crypt/xca/xca-0.5.1-r1.ebuild
+++ b/app-crypt/xca/xca-0.5.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.5.1-r1.ebuild,v 1.1 2006/10/06 22:41:18 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.5.1-r1.ebuild,v 1.2 2006/10/27 01:34:44 alonbl Exp $
inherit eutils kde toolchain-funcs
-DESCRIPTION="a graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
HOMEPAGE="http://www.hohnstaedt.de/xca.html"
SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
@@ -19,23 +19,22 @@ DEPEND=">=dev-libs/openssl-0.9.8
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc4.patch
- epatch ${FILESDIR}/${P}-openssl.patch
- epatch ${FILESDIR}/${P}-qt.diff
- epatch ${FILESDIR}/configure-db.patch
- echo "inst_prefix=/usr" >> Local.mak
- epatch ${FILESDIR}/Rules.mak-prefix.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-openssl.patch"
+ epatch "${FILESDIR}/${P}-qt.patch"
}
src_compile() {
kde_src_compile nothing
- CC=$(tc-getCC) prefix=/usr ./configure || die "configure died"
- inst_prefix=/usr emake || die "emake failed"
+ STRIP="true" CC="$(tc-getCC)" prefix=/usr ./configure || die "configure died"
+ echo "inst_prefix=/usr" >> Local.mak
+ inst_prefix="/usr" emake || die "emake failed"
}
src_install() {
- make destdir=${D} mandir=share/man install
+ make destdir="${D}" mandir="share/man" install
dodoc README CREDITS AUTHORS COPYRIGHT