summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-23 09:52:37 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-23 09:52:37 +0000
commitc3fc8bbe7cebdb3646f2f134d3cdeea6db9de901 (patch)
tree6ee07b0594b6ad5da604ef00069a74a8f9ff2c48 /app-crypt/trousers
parentVersion bump (#224975) (diff)
downloadgentoo-2-c3fc8bbe7cebdb3646f2f134d3cdeea6db9de901.tar.gz
gentoo-2-c3fc8bbe7cebdb3646f2f134d3cdeea6db9de901.tar.bz2
gentoo-2-c3fc8bbe7cebdb3646f2f134d3cdeea6db9de901.zip
Fix for gcc-4.3, tidy up ebuild. Bug #232521. Thanks to Shvetsov Alexey <alexxyum@gmail.com>
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-crypt/trousers')
-rw-r--r--app-crypt/trousers/ChangeLog8
-rw-r--r--app-crypt/trousers/files/trousers-0.2.3-nouseradd.patch8
-rw-r--r--app-crypt/trousers/files/trousers-0.3.1-gcc43.patch30
-rw-r--r--app-crypt/trousers/trousers-0.3.1.ebuild18
4 files changed, 47 insertions, 17 deletions
diff --git a/app-crypt/trousers/ChangeLog b/app-crypt/trousers/ChangeLog
index 1e011c9d8cea..c83b6b5ef212 100644
--- a/app-crypt/trousers/ChangeLog
+++ b/app-crypt/trousers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/trousers
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.17 2008/06/07 20:54:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.18 2008/07/23 09:52:37 loki_val Exp $
+
+ 23 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ files/trousers-0.2.3-nouseradd.patch, +files/trousers-0.3.1-gcc43.patch,
+ trousers-0.3.1.ebuild:
+ Fix for gcc-4.3, tidy up ebuild. Bug #232521. Thanks to Shvetsov Alexey
+ <alexxyum@gmail.com>
07 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> trousers-0.3.1.ebuild:
Remove unused inherits that were used to patch and re-autotools before.
diff --git a/app-crypt/trousers/files/trousers-0.2.3-nouseradd.patch b/app-crypt/trousers/files/trousers-0.2.3-nouseradd.patch
index 27d71151e074..3b44ed320111 100644
--- a/app-crypt/trousers/files/trousers-0.2.3-nouseradd.patch
+++ b/app-crypt/trousers/files/trousers-0.2.3-nouseradd.patch
@@ -1,5 +1,5 @@
---- Makefile.am.orig 2005-07-30 19:33:46.000000000 +1000
-+++ Makefile.am 2005-07-30 19:34:09.000000000 +1000
+--- dist/Makefile.am.orig 2005-07-30 19:33:46.000000000 +1000
++++ dist/Makefile.am 2005-07-30 19:34:09.000000000 +1000
@@ -9,8 +9,6 @@
/bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
@@ -9,8 +9,8 @@
/bin/chown tss:tss ${DESTDIR}/@sbindir@/tcsd
/bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
/bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm
---- Makefile.in.orig 2005-07-30 19:33:52.000000000 +1000
-+++ Makefile.in 2005-07-30 19:34:22.000000000 +1000
+--- dist/Makefile.in.orig 2005-07-30 19:33:52.000000000 +1000
++++ dist/Makefile.in 2005-07-30 19:34:22.000000000 +1000
@@ -369,8 +369,6 @@
/bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
diff --git a/app-crypt/trousers/files/trousers-0.3.1-gcc43.patch b/app-crypt/trousers/files/trousers-0.3.1-gcc43.patch
new file mode 100644
index 000000000000..db0f48e5f8b9
--- /dev/null
+++ b/app-crypt/trousers/files/trousers-0.3.1-gcc43.patch
@@ -0,0 +1,30 @@
+--- src/trspi/crypto/openssl/symmetric.c.orig 2008-07-21 02:14:44.000000000 +0400
++++ src/trspi/crypto/openssl/symmetric.c 2008-07-21 02:15:06.000000000 +0400
+@@ -16,6 +16,7 @@
+ */
+
+ #include <string.h>
++#include <limits.h>
+
+ #include <openssl/evp.h>
+ #include <openssl/err.h>
+--- src/tspi/tsp_ps.c.orig 2008-07-21 02:27:14.000000000 +0400
++++ src/tspi/tsp_ps.c 2008-07-21 02:27:40.000000000 +0400
+@@ -15,6 +15,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <limits.h>
+
+ #include "trousers/tss.h"
+ #include "trousers/trousers.h"
+--- src/tspi/tspi_aik.c.orig 2008-07-21 02:31:35.000000000 +0400
++++ src/tspi/tspi_aik.c 2008-07-21 02:32:04.000000000 +0400
+@@ -12,6 +12,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <inttypes.h>
++#include <limits.h>
+
+ #include "trousers/tss.h"
+ #include "trousers/trousers.h"
diff --git a/app-crypt/trousers/trousers-0.3.1.ebuild b/app-crypt/trousers/trousers-0.3.1.ebuild
index 446a8903dc14..b14e33cf208c 100644
--- a/app-crypt/trousers/trousers-0.3.1.ebuild
+++ b/app-crypt/trousers/trousers-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/trousers-0.3.1.ebuild,v 1.3 2008/06/07 20:54:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/trousers-0.3.1.ebuild,v 1.4 2008/07/23 09:52:37 loki_val Exp $
-inherit eutils linux-info
+inherit base eutils linux-info
DESCRIPTION="An open-source TCG Software Stack (TSS) v1.1 implementation"
HOMEPAGE="http://trousers.sf.net"
@@ -19,6 +19,10 @@ RDEPEND=">=dev-libs/glib-2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-0.2.3-nouseradd.patch"
+ "${FILESDIR}/${P}-qa.patch"
+ "${FILESDIR}/${P}-gcc43.patch" )
+
pkg_setup() {
# Check for driver (not sure it can be an rdep, because ot depends on the
# version of virtual/linux-sources... Is that supported by portage?)
@@ -58,16 +62,6 @@ pkg_setup() {
enewuser tss -1 -1 /var/lib/tpm tss
}
-src_unpack() {
- unpack ${A}
- cd "${S}/dist"
- #http://sourceforge.net/tracker/index.php?func=detail&aid=1829497&group_id=126012&atid=704361
- epatch "${FILESDIR}/${PN}-0.2.3-nouseradd.patch"
- cd "${S}"
- #http://sourceforge.net/tracker/index.php?func=detail&aid=1794686&group_id=126012&atid=704358
- epatch "${FILESDIR}/${P}-qa.patch"
-}
-
src_install() {
keepdir /var/lib/tpm
make DESTDIR="${D}" install || die