summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-11-30 13:21:06 +0000
committerDane Smith <c1pher@gentoo.org>2010-11-30 13:21:06 +0000
commit3e996cc3c33b309da9565ce448dd408e2ce1eb12 (patch)
tree513e41b3e411506f3e35ca1cf6a1c512207eb001 /app-crypt/tpm-tools
parentRemoved because of multiple breakage (diff)
downloadgentoo-2-3e996cc3c33b309da9565ce448dd408e2ce1eb12.tar.gz
gentoo-2-3e996cc3c33b309da9565ce448dd408e2ce1eb12.tar.bz2
gentoo-2-3e996cc3c33b309da9565ce448dd408e2ce1eb12.zip
Version bump for tpm-tools wrt bug 329457.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'app-crypt/tpm-tools')
-rw-r--r--app-crypt/tpm-tools/ChangeLog11
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.5.ebuild35
2 files changed, 44 insertions, 2 deletions
diff --git a/app-crypt/tpm-tools/ChangeLog b/app-crypt/tpm-tools/ChangeLog
index 9ac2944d6f09..6fccc30dea08 100644
--- a/app-crypt/tpm-tools/ChangeLog
+++ b/app-crypt/tpm-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/tpm-tools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-tools/ChangeLog,v 1.10 2009/05/10 23:11:27 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-tools/ChangeLog,v 1.11 2010/11/30 13:21:06 c1pher Exp $
+
+*tpm-tools-1.3.5 (30 Nov 2010)
+
+ 30 Nov 2010; Dane Smith <c1pher@gentoo.org> +tpm-tools-1.3.5.ebuild:
+ Version bump to 1.3.5 wrt bug 329457.
+ *Moved to EAPI 2.
+ *A few small QA fixes.
10 May 2009; Robin H. Johnson <robbat2@gentoo.org> tpm-tools-1.3.1.ebuild:
Working on this for ~amd64.
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.5.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.5.ebuild
new file mode 100644
index 000000000000..a2010d10e744
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-tools/tpm-tools-1.3.5.ebuild,v 1.1 2010/11/30 13:21:06 c1pher Exp $
+
+EAPI="2"
+inherit autotools
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+COMMON_DEPEND=">=app-crypt/trousers-0.3.0"
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )"
+# TODO: add optionnal opencryptoki support
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" configure.in || die "Sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die
+}