summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-03-30 01:46:43 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-03-30 01:46:43 +0000
commita0dfece90b2691cbbf737eb92622f7b1ecb5d30e (patch)
treef02ddcfb9ff24e84891be363410e96fb4b5f69a2 /app-crypt/steghide
parentRemove old versions. (diff)
downloadgentoo-2-a0dfece90b2691cbbf737eb92622f7b1ecb5d30e.tar.gz
gentoo-2-a0dfece90b2691cbbf737eb92622f7b1ecb5d30e.tar.bz2
gentoo-2-a0dfece90b2691cbbf737eb92622f7b1ecb5d30e.zip
bug 83840
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-crypt/steghide')
-rw-r--r--app-crypt/steghide/ChangeLog9
-rw-r--r--app-crypt/steghide/files/steghide-0.5.1-gcc34.patch29
-rw-r--r--app-crypt/steghide/steghide-0.5.1.ebuild7
3 files changed, 43 insertions, 2 deletions
diff --git a/app-crypt/steghide/ChangeLog b/app-crypt/steghide/ChangeLog
index c46f7627d3e3..ebee28175224 100644
--- a/app-crypt/steghide/ChangeLog
+++ b/app-crypt/steghide/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/steghide
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/ChangeLog,v 1.6 2005/01/01 12:39:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/ChangeLog,v 1.7 2005/03/30 01:46:43 vanquirius Exp $
+
+ 29 Mar 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/steghide-0.5.1-gcc34.patch, steghide-0.5.1.ebuild:
+ Adding patch so that steghide can be compiled with gcc-3.4. The patch is taken
+ from Debian and can be found in bug 274184 in their bug tracking system. This
+ fixes our bug 83840. Thanks to Thomas Beinicke <Merlin-TC@web.de> for
+ reporting the bug.
30 Jul 2004; Tony Vroon <chainsaw@gentoo.org>
+files/fix-libtool-invocation.patch, steghide-0.5.1.ebuild:
diff --git a/app-crypt/steghide/files/steghide-0.5.1-gcc34.patch b/app-crypt/steghide/files/steghide-0.5.1-gcc34.patch
new file mode 100644
index 000000000000..01b49a50c743
--- /dev/null
+++ b/app-crypt/steghide/files/steghide-0.5.1-gcc34.patch
@@ -0,0 +1,29 @@
+diff -urN ../tmp-orig/steghide-0.5.1/src/AuSampleValues.cc ./src/AuSampleValues.cc
+--- ../tmp-orig/steghide-0.5.1/src/AuSampleValues.cc 2003-09-28 17:30:30.000000000 +0200
++++ ./src/AuSampleValues.cc 2004-09-30 10:20:54.982240968 +0200
+@@ -21,17 +21,17 @@
+ #include "AuSampleValues.h"
+
+ // AuMuLawSampleValue
+-const BYTE AuMuLawSampleValue::MinValue = 0 ;
+-const BYTE AuMuLawSampleValue::MaxValue = BYTE_MAX ;
++template <> const BYTE AuMuLawSampleValue::MinValue = 0 ;
++template <> const BYTE AuMuLawSampleValue::MaxValue = BYTE_MAX ;
+
+ // AuPCM8SampleValue
+-const SBYTE AuPCM8SampleValue::MinValue = SBYTE_MIN ;
+-const SBYTE AuPCM8SampleValue::MaxValue = SBYTE_MAX ;
++template <> const SBYTE AuPCM8SampleValue::MinValue = SBYTE_MIN ;
++template <> const SBYTE AuPCM8SampleValue::MaxValue = SBYTE_MAX ;
+
+ // AuPCM16SampleValue
+-const SWORD16 AuPCM16SampleValue::MinValue = SWORD16_MIN ;
+-const SWORD16 AuPCM16SampleValue::MaxValue = SWORD16_MAX ;
++template <> const SWORD16 AuPCM16SampleValue::MinValue = SWORD16_MIN ;
++template <> const SWORD16 AuPCM16SampleValue::MaxValue = SWORD16_MAX ;
+
+ // AuPCM32SampleValue
+-const SWORD32 AuPCM32SampleValue::MinValue = SWORD32_MIN ;
+-const SWORD32 AuPCM32SampleValue::MaxValue = SWORD32_MAX ;
++template <> const SWORD32 AuPCM32SampleValue::MinValue = SWORD32_MIN ;
++template <> const SWORD32 AuPCM32SampleValue::MaxValue = SWORD32_MAX ;
diff --git a/app-crypt/steghide/steghide-0.5.1.ebuild b/app-crypt/steghide/steghide-0.5.1.ebuild
index 35b3119f6679..a8316d3c6c8a 100644
--- a/app-crypt/steghide/steghide-0.5.1.ebuild
+++ b/app-crypt/steghide/steghide-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.5 2005/01/01 12:39:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.6 2005/03/30 01:46:43 vanquirius Exp $
inherit eutils
@@ -17,6 +17,11 @@ DEPEND=">=app-crypt/mhash-0.8.18-r1
>=media-libs/jpeg-6b-r3
>=sys-libs/zlib-1.1.4-r2"
+src_unpack(){
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
econf || die "configure failed"
epatch ${FILESDIR}/fix-libtool-invocation.patch