summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-16 23:20:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-16 23:20:29 +0000
commit0af2e5a53a217f4104286c0d8348ea2173f55f5e (patch)
treefaddb54c6e32e70331d4228abe649392d35be377 /app-crypt/rotix
parentStable on amd64 wrt bug #328485 (diff)
downloadgentoo-2-0af2e5a53a217f4104286c0d8348ea2173f55f5e.tar.gz
gentoo-2-0af2e5a53a217f4104286c0d8348ea2173f55f5e.tar.bz2
gentoo-2-0af2e5a53a217f4104286c0d8348ea2173f55f5e.zip
Apply patch from Dane Smith to fix compilation problems with USE=nls and -O0. Bug #239964. Respect LDFLAGS and drop custom CFLAGS for debug mode
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/rotix')
-rw-r--r--app-crypt/rotix/ChangeLog9
-rw-r--r--app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch26
-rw-r--r--app-crypt/rotix/files/rotix-0.83-locale.diff10
-rw-r--r--app-crypt/rotix/rotix-0.83.ebuild13
4 files changed, 41 insertions, 17 deletions
diff --git a/app-crypt/rotix/ChangeLog b/app-crypt/rotix/ChangeLog
index 4d853d0ef284..38e0e966c8be 100644
--- a/app-crypt/rotix/ChangeLog
+++ b/app-crypt/rotix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/rotix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.12 2010/02/22 18:37:02 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.13 2010/07/16 23:20:29 hwoarang Exp $
+
+ 16 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ files/0.83-respect-CFLAGS-and-dont-strip.patch, rotix-0.83.ebuild,
+ +files/rotix-0.83-locale.diff:
+ Apply patch from Dane Smith <smithdanea@gmail.com> to fix compilation
+ problems with USE=nls and -O0. Bug #239964. Respect LDFLAGS and drop
+ custom CFLAGS for debug mode
22 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> rotix-0.83.ebuild:
Make the gettext dependency required, wrt bug #232897 by mduft.
diff --git a/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
index 85498d2e03af..ab23372e768f 100644
--- a/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
+++ b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
@@ -1,23 +1,31 @@
---- Makefile.orig 2007-03-21 22:43:39.000000000 +0100
-+++ Makefile 2007-03-21 22:44:16.000000000 +0100
-@@ -24,8 +24,6 @@
+Index: rotix-0.83/Makefile
+===================================================================
+--- rotix-0.83.orig/Makefile
++++ rotix-0.83/Makefile
+@@ -22,12 +22,6 @@
- ifdef DEBUG
- CFLAGS += -g3
+ include Makefile.settings
+
+-ifdef DEBUG
+-CFLAGS += -g3
-else
-CFLAGS += -O3
- endif
-
+-endif
+-
ifdef I18N
-@@ -40,11 +38,6 @@
+ CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALE}\"
+ endif
+@@ -39,12 +33,7 @@ endif
+ all : rotix po
rotix : rot.o help.o rotix.o
- $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
+- $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
-ifdef STRIP
-ifndef DEBUG
- $(STRIP) rotix
-endif
-endif
++ $(CC) -Wall $(CFLAGS) $(LDFLAGS) -o rotix rot.o help.o rotix.o
ifdef I18N
CFLAGS += -D I18N=1
diff --git a/app-crypt/rotix/files/rotix-0.83-locale.diff b/app-crypt/rotix/files/rotix-0.83-locale.diff
new file mode 100644
index 000000000000..844a452b8af1
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-locale.diff
@@ -0,0 +1,10 @@
+--- rotix.c 2002-04-02 14:48:42.000000000 -0500
++++ rotix.c.mine 2010-07-15 14:54:45.000000000 -0400
+@@ -38,6 +38,7 @@
+ /* I18N */
+ #ifdef I18N
+ #include <libintl.h>
++#include <locale.h>
+ #define _(String) gettext (String)
+ #else
+ #define _(String) String
diff --git a/app-crypt/rotix/rotix-0.83.ebuild b/app-crypt/rotix/rotix-0.83.ebuild
index 627ca8a4ccfa..b1fbcdd6310c 100644
--- a/app-crypt/rotix/rotix-0.83.ebuild
+++ b/app-crypt/rotix/rotix-0.83.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.14 2010/02/22 18:37:02 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.15 2010/07/16 23:20:29 hwoarang Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Rotix allows you to generate rotational obfuscations."
@@ -10,21 +11,19 @@ SRC_URI="http://elektron.its.tudelft.nl/~hemmin98/rotix_releases/${P}/${P}.tar.b
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64 ia64"
+KEYWORDS="amd64 ia64 ppc x86"
IUSE=""
DEPEND="sys-devel/gettext"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PV}-respect-CFLAGS-and-dont-strip.patch
+ epatch "${FILESDIR}"/${P}-locale.diff
}
-src_compile() {
+src_configure() {
econf --i18n=1
- emake || die
}
src_install() {