summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-30 21:32:40 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-30 21:32:40 +0000
commitf8a54c27763dbe4509f8b04c8af6738d807ced0e (patch)
treebd36ac70c417eb49ab79765332ce3ba9881e1099 /app-crypt/qca
parentold (diff)
downloadgentoo-2-f8a54c27763dbe4509f8b04c8af6738d807ced0e.tar.gz
gentoo-2-f8a54c27763dbe4509f8b04c8af6738d807ced0e.tar.bz2
gentoo-2-f8a54c27763dbe4509f8b04c8af6738d807ced0e.zip
Fix test phase to load the just-built plugins (bug 553530).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog5
-rw-r--r--app-crypt/qca/qca-2.1.0.3.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 603ddf5e2434..6950b43cce83 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.110 2015/06/29 00:55:26 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.111 2015/06/30 21:32:40 pesa Exp $
+
+ 30 Jun 2015; Davide Pesavento <pesa@gentoo.org> qca-2.1.0.3.ebuild:
+ Fix test phase to load the just-built plugins (bug 553530).
29 Jun 2015; Davide Pesavento <pesa@gentoo.org> qca-2.1.0.3.ebuild:
Use qmake-utils helper functions to simplify src_configure. Remove double call
diff --git a/app-crypt/qca/qca-2.1.0.3.ebuild b/app-crypt/qca/qca-2.1.0.3.ebuild
index a9bac0501e98..67818f2839b5 100644
--- a/app-crypt/qca/qca-2.1.0.3.ebuild
+++ b/app-crypt/qca/qca-2.1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.1.0.3.ebuild,v 1.10 2015/06/29 00:55:26 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.1.0.3.ebuild,v 1.11 2015/06/30 21:32:40 pesa Exp $
EAPI=5
@@ -99,7 +99,12 @@ src_compile() {
}
src_test() {
- multibuild_foreach_variant cmake-utils_src_test
+ mytest() {
+ local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
+ cmake-utils_src_test
+ }
+
+ multibuild_foreach_variant mytest
}
src_install() {