summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-09-19 08:37:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-09-19 08:37:34 +0000
commitbe694cc6624761697c0b5a7ef0470f09f88afe7a (patch)
treecd58505942ce9f97476c99d07bc73cdfe9d033f5 /app-crypt/onak/onak-0.3.2.ebuild
parentversion bump (diff)
downloadgentoo-2-be694cc6624761697c0b5a7ef0470f09f88afe7a.tar.gz
gentoo-2-be694cc6624761697c0b5a7ef0470f09f88afe7a.tar.bz2
gentoo-2-be694cc6624761697c0b5a7ef0470f09f88afe7a.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-crypt/onak/onak-0.3.2.ebuild')
-rw-r--r--app-crypt/onak/onak-0.3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/onak/onak-0.3.2.ebuild b/app-crypt/onak/onak-0.3.2.ebuild
new file mode 100644
index 000000000000..790db7143665
--- /dev/null
+++ b/app-crypt/onak/onak-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/onak/onak-0.3.2.ebuild,v 1.1 2005/09/19 08:37:34 robbat2 Exp $
+
+DESCRIPTION="onak is an OpenPGP keyserver"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/onak.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="=sys-libs/db-4*"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ keepdir /var/lib/onak
+ dosbin onak maxpath sixdegrees onak-mail.pl
+ dobin splitkeys stripkey
+ doman *.[1-8]
+ insinto /etc
+ doins onak.conf
+
+ # these are CGI stuff that I don't want to deal with yet
+ #dobin lookup add gpgwww
+ sed -i \
+ -e 's,^www_port 11371,www_port 0,g' \
+ -e 's,^db_dir /var/lib/lib/onak,db_dir /var/lib/onak,g' \
+ -e 's,^logfile /var/lib/log/onak.log,logfile /var/log/onak.log,g' \
+ -e 's,^max_last 1,max_last 0,g' \
+ ${D}/etc/onak.conf
+}