summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 15:31:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 15:31:25 +0000
commit75a4f10e807076790e201c5f969644e5a2f5c256 (patch)
treeee9d1bb093e6be51af347a9db499163e87b4d968 /app-crypt/heimdal
parentadded ppc to keywords (diff)
downloadgentoo-2-75a4f10e807076790e201c5f969644e5a2f5c256.tar.gz
gentoo-2-75a4f10e807076790e201c5f969644e5a2f5c256.tar.bz2
gentoo-2-75a4f10e807076790e201c5f969644e5a2f5c256.zip
repoman'd
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/heimdal-0.4e-r1.ebuild38
1 files changed, 15 insertions, 23 deletions
diff --git a/app-crypt/heimdal/heimdal-0.4e-r1.ebuild b/app-crypt/heimdal/heimdal-0.4e-r1.ebuild
index f849cfe25bfe..a5982c5c93f5 100644
--- a/app-crypt/heimdal/heimdal-0.4e-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.4e-r1.ebuild
@@ -1,14 +1,17 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.4e-r1.ebuild,v 1.3 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.4e-r1.ebuild,v 1.4 2002/07/25 15:31:24 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Kerberos 5 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/heimdal/"
-DEPEND="virtual/glibc
- >=app-crypt/kth-krb-1.1-r1
+SLOT="0"
+LICENSE=""
+KEYWORDS="x86"
+
+DEPEND=">=app-crypt/kth-krb-1.1-r1
ssl? ( dev-libs/openssl )
ldap? ( net-nds/openldap )
berkdb? ( sys-libs/db )"
@@ -16,27 +19,19 @@ DEPEND="virtual/glibc
src_compile() {
local myconf
- if [ "`use ssl`" ] ; then
- myconf="--with-openssl=/usr"
- fi
+ use ssl && myconf="--with-openssl=/usr"
- if [ "`use ldap`" ] ; then
- myconf="${myconf} --with-open-ldap=/usr"
- fi
+ use ldap && myconf="${myconf} --with-open-ldap=/usr"
- if [ -z "`use ipv6`" ] ; then
- myconf="${myconf} --without-ipv6"
- fi
+ use ipv6 || myconf="${myconf} --without-ipv6"
- if [ -z "`use berkdb`" ] ; then
- myconf="${myconf} --without-berkely-db"
- fi
+ use berkdb || myconf="${myconf} --without-berkely-db"
./configure --host=${CHOST} \
- --prefix=/usr/heimdal \
- --sysconfdir=/etc \
- --with-krb4=/usr/athena \
- ${myconf} || die
+ --prefix=/usr/heimdal \
+ --sysconfdir=/etc \
+ --with-krb4=/usr/athena \
+ ${myconf} || die
emake || die
}
@@ -51,6 +46,3 @@ src_install () {
dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
}
-
-
-