summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-04-21 17:57:07 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-04-21 17:57:07 +0000
commitf07cee9b210f4ecfecad05a3edb81a74012f196d (patch)
tree77a155009e1c3630e116cc969d5e1cba9fe4f94b /app-crypt/gnupg
parent*** empty log message *** (diff)
downloadgentoo-2-f07cee9b210f4ecfecad05a3edb81a74012f196d.tar.gz
gentoo-2-f07cee9b210f4ecfecad05a3edb81a74012f196d.tar.bz2
gentoo-2-f07cee9b210f4ecfecad05a3edb81a74012f196d.zip
Added a new package GNUPG
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/gnupg-1.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/gnupg/gnupg-1.0.4.ebuild b/app-crypt/gnupg/gnupg-1.0.4.ebuild
new file mode 100644
index 000000000000..75f3a45990be
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${A}"
+HOMEPAGE="http://www.gnupg.org/"
+
+DEPEND=">=sys-devel/gettext-0.10.35
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share \
+ --enable-static-rnd=linux --enable-m-guard --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc faq.html faq.raw gpg.sgml gpgv.sgml FAQ HACKING DETAILS ChangeLog
+
+}
+