summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-08-22 11:50:24 +0000
committerRoy Marples <uberlord@gentoo.org>2007-08-22 11:50:24 +0000
commit7e1eb23d0a5f68622007db0968344c79bf35c510 (patch)
tree1b8313e5b6323ccfccd6be51c666080b0f3c0fc6 /app-cdr/cdrdao
parentKeyworded ~x86-fbsd. (diff)
downloadgentoo-2-7e1eb23d0a5f68622007db0968344c79bf35c510.tar.gz
gentoo-2-7e1eb23d0a5f68622007db0968344c79bf35c510.tar.bz2
gentoo-2-7e1eb23d0a5f68622007db0968344c79bf35c510.zip
Add a patch to not compile linux code for non linux machines. Keyworded ~x86-fbsd.
(Portage version: 2.1.3.6)
Diffstat (limited to 'app-cdr/cdrdao')
-rw-r--r--app-cdr/cdrdao/ChangeLog9
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.2.ebuild12
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch12
3 files changed, 28 insertions, 5 deletions
diff --git a/app-cdr/cdrdao/ChangeLog b/app-cdr/cdrdao/ChangeLog
index fa41d0da27d4..278004c8aa1d 100644
--- a/app-cdr/cdrdao/ChangeLog
+++ b/app-cdr/cdrdao/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-cdr/cdrdao
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/ChangeLog,v 1.98 2006/11/04 15:46:40 metalgod Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/ChangeLog,v 1.99 2007/08/22 11:50:24 uberlord Exp $
+
+ 22 Aug 2007; Roy Marples <uberlord@gentoo.org>
+ +files/cdrdao-1.2.2-nonlinux.patch, cdrdao-1.2.2.ebuild:
+ Add a patch to not compile linux code for non linux machines.
+ Keyworded ~x86-fbsd.
*cdrdao-1.2.2 (04 Nov 2006)
diff --git a/app-cdr/cdrdao/cdrdao-1.2.2.ebuild b/app-cdr/cdrdao/cdrdao-1.2.2.ebuild
index df1ce1162bc6..cfb601d5f86b 100644
--- a/app-cdr/cdrdao/cdrdao-1.2.2.ebuild
+++ b/app-cdr/cdrdao/cdrdao-1.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/cdrdao-1.2.2.ebuild,v 1.2 2006/11/04 15:47:25 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/cdrdao-1.2.2.ebuild,v 1.3 2007/08/22 11:50:24 uberlord Exp $
inherit flag-o-matic eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/cdrdao/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="gnome debug encode pccts"
RESTRICT="strip"
@@ -29,6 +29,12 @@ src_unpack() {
unpack ${A}
cd ${S}
+ # FreeBSD needs this patch
+ # I think the correct define should be linux, but this will maintain
+ # the status quo for the time being.
+ # Upstream bug #1596097
+ epatch "${FILESDIR}/${P}"-nonlinux.patch
+
# Display better SCSI messages (advise from Bug 43003)
cd scsilib/include
sed -i -e 's:HAVE_SCANSTACK:NO_FRIGGING_SCANSTACK:g' xmconfig.h
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch b/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch
new file mode 100644
index 000000000000..a5800d37925d
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch
@@ -0,0 +1,12 @@
+diff -ur a/dao/ScsiIf-lib.cc b/dao/ScsiIf-lib.cc
+--- a/dao/ScsiIf-lib.cc 2007-08-22 12:21:11 +0100
++++ b/dao/ScsiIf-lib.cc 2007-08-22 12:25:04 +0100
+@@ -430,7 +430,7 @@
+ #include "ScsiIf-common.cc"
+ //<<<<<<< ScsiIf-lib.cc
+
+-#ifndef linux
++#ifdef wedontwantthis
+
+ /* Function for mapping any SCSI device to the corresponding SG device.
+ * Taken from D. Gilbert's example code.