summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2007-09-12 02:27:46 +0000
committerStephen Klimaszewski <steev@gentoo.org>2007-09-12 02:27:46 +0000
commit5dac3c6ce596838a58fbd3d738caf9aec49b8f18 (patch)
tree8b4ab29f398ab7919e9722f73d4e63c4f7a0299e /app-benchmarks
parentretire older stuff to toolchain overlay (diff)
downloadgentoo-2-5dac3c6ce596838a58fbd3d738caf9aec49b8f18.tar.gz
gentoo-2-5dac3c6ce596838a58fbd3d738caf9aec49b8f18.tar.bz2
gentoo-2-5dac3c6ce596838a58fbd3d738caf9aec49b8f18.zip
New upstream release, various bugfixes. Permission from robbat2 to bump since we use it at work.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog8
-rw-r--r--app-benchmarks/siege/files/digest-siege-2.663
-rw-r--r--app-benchmarks/siege/siege-2.66.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index f37150cfbc7a..3b2fd50dc332 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.39 2007/03/19 02:16:18 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.40 2007/09/12 02:27:45 steev Exp $
+
+*siege-2.66 (12 Sep 2007)
+
+ 12 Sep 2007; Steev Klimaszewski <steev@gentoo.org> +siege-2.66.ebuild:
+ New upstream release, various bugfixes. Permission from robbat2 to bump
+ since we use it at work.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/app-benchmarks/siege/files/digest-siege-2.66 b/app-benchmarks/siege/files/digest-siege-2.66
new file mode 100644
index 000000000000..2d4ba28892a8
--- /dev/null
+++ b/app-benchmarks/siege/files/digest-siege-2.66
@@ -0,0 +1,3 @@
+MD5 a5592e42d4217572d8035dec000f479c siege-2.66.tar.gz 478161
+RMD160 25cd395432477cda02d04da3b7c72e6c15008714 siege-2.66.tar.gz 478161
+SHA256 c4b4aefc94e42f6817445ea88725b8058fcb87d238c1b3a7f9f3d21cde057be5 siege-2.66.tar.gz 478161
diff --git a/app-benchmarks/siege/siege-2.66.ebuild b/app-benchmarks/siege/siege-2.66.ebuild
new file mode 100644
index 000000000000..38b8e372a45c
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.66.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.66.ebuild,v 1.1 2007/09/12 02:27:45 steev Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="ftp://sid.joedog.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="debug ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-2.60-gentoo.diff
+
+ # use of \b causes the T in "Transactions" to be displayed
+ # on the last column of the previous line.
+ sed -i 's/\\b\(Transactions:\)/\1/' src/main.c || \
+ die "sed src/main.c failed"
+
+ automake || die "automake failed"
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+
+ econf ${myconf} \
+ $(use_with debug debugging) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ siegerc-example urls.txt || die "dodoc failed"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+
+ for x in $(find ${D}/usr/bin -name '*.pl') ; do mv "${x}" "${x%.*}" ; done
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed as"
+ elog "/usr/share/doc/${PF}/siegerc-example.gz"
+ bash-completion_pkg_postinst
+}