summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-24 12:53:34 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-24 12:53:34 +0000
commitb7a93b334d44c1e1dd7b9d6986695cf92f068dc9 (patch)
tree92d61c0796b327dd632b805ee83e26d0ea161367 /app-benchmarks/bootchart2
parentSupport python 3.4 (diff)
downloadgentoo-2-b7a93b334d44c1e1dd7b9d6986695cf92f068dc9.tar.gz
gentoo-2-b7a93b334d44c1e1dd7b9d6986695cf92f068dc9.tar.bz2
gentoo-2-b7a93b334d44c1e1dd7b9d6986695cf92f068dc9.zip
app-benchmarks/bootchart2: Version Bump; Add python3_4 support, #530342
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-benchmarks/bootchart2')
-rw-r--r--app-benchmarks/bootchart2/ChangeLog9
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.7.ebuild78
2 files changed, 85 insertions, 2 deletions
diff --git a/app-benchmarks/bootchart2/ChangeLog b/app-benchmarks/bootchart2/ChangeLog
index b8b8d883eba4..266ee12c4396 100644
--- a/app-benchmarks/bootchart2/ChangeLog
+++ b/app-benchmarks/bootchart2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/bootchart2
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.19 2013/09/05 19:44:51 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.20 2014/11/24 12:53:34 jlec Exp $
+
+*bootchart2-0.14.7 (24 Nov 2014)
+
+ 24 Nov 2014; Justin Lecher <jlec@gentoo.org> +bootchart2-0.14.7.ebuild:
+ Version Bump; Add python3_4 support, #530342
05 Sep 2013; Michał Górny <mgorny@gentoo.org> bootchart2-0.14.5-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.7.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.7.ebuild
new file mode 100644
index 000000000000..18dbcf720e30
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/bootchart2-0.14.7.ebuild,v 1.1 2014/11/24 12:53:34 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit linux-info python-r1 systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg test X"
+
+REQUIRED_USE="
+ X? ( ${PYTHON_REQUIRED_USE} )
+ test? ( X )"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ X? (
+ dev-python/pycairo[svg?,${PYTHON_USEDEP}]
+ dev-python/pygtk[$(python_gen_usedep 'python2*')]
+ ${PYTHON_DEPS}
+ )
+ sys-apps/lsb-release"
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"/${PN%2}-${PV}
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ -i Makefile || die
+ sed \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty":g' \
+ -i bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ python_foreach_impl emake test
+}
+
+src_install() {
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ python_domodule pybootchartgui
+
+ python_newscript pybootchartgui.py pybootchartgui
+ }
+ use X && python_foreach_impl installation
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+}
+
+pkg_postinst() {
+ elog "If you are using an initrd during boot"
+ echo
+ elog "please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo
+}