summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 20:54:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 20:54:39 +0000
commitc8f95c5999b4bd70e62dba04a9bd38a1c1295497 (patch)
tree2d6f1215f895c0936bd6d365c2e2a9b68a2ad4cd /app-benchmarks/bonnie++
parentAdded security patches from bug #54976 (Manifest recommit) (diff)
downloadgentoo-2-c8f95c5999b4bd70e62dba04a9bd38a1c1295497.tar.gz
gentoo-2-c8f95c5999b4bd70e62dba04a9bd38a1c1295497.tar.bz2
gentoo-2-c8f95c5999b4bd70e62dba04a9bd38a1c1295497.zip
touch the libc
Diffstat (limited to 'app-benchmarks/bonnie++')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.03.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
index 3f580ca15b3a..93442620cc96 100644
--- a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
+++ b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.8 2004/06/24 21:27:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.9 2004/06/27 20:52:15 vapier Exp $
DESCRIPTION="Hard drive bottleneck testing benchmark suite."
HOMEPAGE="http://www.coker.com.au/bonnie++/"
@@ -11,23 +11,21 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc alpha ~amd64"
IUSE="debug"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
- local myconf="`use_with debug`"
- use debug \
- && myconf="${myconf} --disable-stripping" \
- || myconf="${myconf} --enable-stripping"
-
- econf ${myconf} || die
+ econf \
+ `use_with debug` \
+ `use_enable !debug stripping` \
+ || die
emake || die "emake failed"
emake zcav || die "emake zcav failed" # see #9073
}
src_install() {
- dosbin bonnie++ zcav
- dobin bon_csv2html bon_csv2txt
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
dohtml readme.html
- dodoc changelog.txt copyright.txt credits.txt
+ dodoc changelog.txt credits.txt
}