summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2005-09-17 13:30:47 +0000
committerFabian Groffen <grobian@gentoo.org>2005-09-17 13:30:47 +0000
commit79d550f062aa88edae56d5b987f33b732c457de1 (patch)
treea9942504b5b1edefe5fa897ef0cd21ee32b265c3 /app-backup
parentVersion bump. Added sasl and gnutls USE flags. (diff)
downloadgentoo-2-79d550f062aa88edae56d5b987f33b732c457de1.tar.gz
gentoo-2-79d550f062aa88edae56d5b987f33b732c457de1.tar.bz2
gentoo-2-79d550f062aa88edae56d5b987f33b732c457de1.zip
Initial commit of boxbackup, based on the work of Mark Spanbroek and Anatoly Shipitsin
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/boxbackup/ChangeLog14
-rw-r--r--app-backup/boxbackup/Manifest7
-rw-r--r--app-backup/boxbackup/boxbackup-0.09.ebuild77
-rw-r--r--app-backup/boxbackup/files/bbackupd.rc21
-rw-r--r--app-backup/boxbackup/files/bbstored.rc21
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.09-darwin.patch11
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch161
-rw-r--r--app-backup/boxbackup/files/digest-boxbackup-0.092
-rw-r--r--app-backup/boxbackup/metadata.xml16
9 files changed, 330 insertions, 0 deletions
diff --git a/app-backup/boxbackup/ChangeLog b/app-backup/boxbackup/ChangeLog
new file mode 100644
index 000000000000..f2c99f12f8bd
--- /dev/null
+++ b/app-backup/boxbackup/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for app-backup/boxbackup
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/ChangeLog,v 1.1 2005/09/17 13:30:46 grobian Exp $
+
+*boxbackup-0.09 (17 Sep 2005)
+
+ 17 Sep 2005; Fabian Groffen <grobian@gentoo.org>
+ +files/boxbackup-0.09-darwin.patch, +files/boxbackup-0.09-gentoo.patch,
+ +files/bbackupd.rc, +files/bbstored.rc, +metadata.xml,
+ +boxbackup-0.09.ebuild:
+ Initial import of boxbackup ebuild, largerly based on the work done by Mark
+ Spanbroek <mark at spanbroek (dot] net>. The Gentoo-patches were made by
+ Anatoly Shipitsin <sauron [at) infocentr dot ru>.
+
diff --git a/app-backup/boxbackup/Manifest b/app-backup/boxbackup/Manifest
new file mode 100644
index 000000000000..179e110b1815
--- /dev/null
+++ b/app-backup/boxbackup/Manifest
@@ -0,0 +1,7 @@
+MD5 ba0035547f2be94605ff4fda2e70cb31 metadata.xml 542
+MD5 23df93d2cfa8fe0e02c69ac28627ea43 boxbackup-0.09.ebuild 2193
+MD5 b6a8c5b08f688c050814445a092fc153 files/bbstored.rc 425
+MD5 10ad8802434518abe87eba09444a4855 files/boxbackup-0.09-darwin.patch 443
+MD5 a5aea4f1d604c930129b8efc62612f51 files/digest-boxbackup-0.09 138
+MD5 21a608266d776fcc9099d8d58418f8ed files/boxbackup-0.09-gentoo.patch 6695
+MD5 a4dcc62b0c8458dfe19611b1a92dfdb3 files/bbackupd.rc 413
diff --git a/app-backup/boxbackup/boxbackup-0.09.ebuild b/app-backup/boxbackup/boxbackup-0.09.ebuild
new file mode 100644
index 000000000000..624928abc1e7
--- /dev/null
+++ b/app-backup/boxbackup/boxbackup-0.09.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.09.ebuild,v 1.1 2005/09/17 13:30:47 grobian Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A completely automatic on-line backup system"
+HOMEPAGE="http://www.fluffy.co.uk/boxbackup/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz
+ mirror://gentoo/${P}-solaris.patch.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86"
+IUSE=""
+DEPEND="sys-libs/zlib
+ sys-libs/db
+ >=dev-libs/openssl-0.9.7
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${DISTDIR}/${P}-solaris.patch.bz2
+ epatch ${FILESDIR}/${P}-darwin.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ # note, we can't use econf here, because configure is a wrapper
+ # around a perl script, not the configure you would normally
+ # expect!!!
+ local myconf=""
+ # GCC4 hack, see
+ # http://lists.warhead.org.uk/pipermail/boxbackup/2005-August/001625.html
+ [ "$(gcc-major-version)" -eq "4" ] && myconf="compile:-DPLATFORM_GCC3"
+ ./configure ${myconf} || die
+ make || die
+}
+
+src_install() {
+ # For the same reason why we can't use econf and emake, we can't do
+ # make install here either, because the installation is some lame
+ # script.
+
+ # create directories the installscript assumes to exist
+ mkdir -p ${D}/usr/sbin
+ make DESTDIR=${D} install || die "install failed"
+ make DESTDIR=${D} install-backup-client || die "client install failed"
+ make DESTDIR=${D} install-backup-server || die "server install failed"
+
+ dodoc *.txt
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bbackupd.rc bbackupd
+ newexe ${FILESDIR}/bbstored.rc bbstored
+
+ keepdir /etc/boxbackup
+}
+
+pkg_preinst() {
+ enewgroup bbstored || die "problem adding group bbstored"
+ enewuser bbstored -1 -1 -1 \
+ || die "problem adding user bbstored"
+}
+
+pkg_postinst() {
+ while read line; do einfo "${line}"; done <<EOF
+After configuring the boxbackup client and/or server, you can start
+the boxbackup daemons using the init scripts /etc/init.d/bbackupd
+and /etc/init.d/bbstored.
+More information about configuring the client can be found at
+${HOMEPAGE}client.html,
+and more information about configuring the server can be found at
+${HOMEPAGE}server.html.
+EOF
+}
diff --git a/app-backup/boxbackup/files/bbackupd.rc b/app-backup/boxbackup/files/bbackupd.rc
new file mode 100644
index 000000000000..8e828e34d92e
--- /dev/null
+++ b/app-backup/boxbackup/files/bbackupd.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/files/bbackupd.rc,v 1.1 2005/09/17 13:30:47 grobian Exp $
+
+depend() {
+ need localmount
+ use net
+}
+
+start() {
+ ebegin "Starting box backup daemon"
+ start-stop-daemon --start --exec /usr/sbin/bbackupd > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping box backup daemon"
+ start-stop-daemon --stop --exec /usr/sbin/bbackupd
+ eend $?
+}
diff --git a/app-backup/boxbackup/files/bbstored.rc b/app-backup/boxbackup/files/bbstored.rc
new file mode 100644
index 000000000000..3c1b0d6e5d2e
--- /dev/null
+++ b/app-backup/boxbackup/files/bbstored.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/files/bbstored.rc,v 1.1 2005/09/17 13:30:47 grobian Exp $
+
+depend() {
+ need localmount
+ use net
+}
+
+start() {
+ ebegin "Starting box backup store daemon"
+ start-stop-daemon --start --exec /usr/sbin/bbstored > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping box backup store daemon"
+ start-stop-daemon --stop --exec /usr/sbin/bbstored
+ eend $?
+}
diff --git a/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch b/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch
new file mode 100644
index 000000000000..c9232e85f62c
--- /dev/null
+++ b/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch
@@ -0,0 +1,11 @@
+diff -Naur boxbackup-0.09-orig/lib/common/BoxPlatform.h boxbackup-0.09/lib/common/BoxPlatform.h
+--- boxbackup-0.09-orig/lib/common/BoxPlatform.h 2005-08-09 19:51:44.000000000 +0200
++++ boxbackup-0.09/lib/common/BoxPlatform.h 2005-08-09 19:51:57.000000000 +0200
+@@ -117,7 +117,6 @@
+ #include <sys/types.h>
+
+ // types 'missing'
+- typedef int socklen_t;
+ typedef u_int8_t uint8_t;
+ typedef signed char int8_t;
+ typedef u_int64_t uint64_t;
diff --git a/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch b/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch
new file mode 100644
index 000000000000..04c9b2f468c5
--- /dev/null
+++ b/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch
@@ -0,0 +1,161 @@
+diff -ruN boxbackup-0.09.orig/bin/bbackupd/bbackupd-config boxbackup-0.09/bin/bbackupd/bbackupd-config
+--- boxbackup-0.09.orig/bin/bbackupd/bbackupd-config 2005-04-18 15:11:17.603115864 +0600
++++ boxbackup-0.09/bin/bbackupd/bbackupd-config 2005-04-18 17:39:43.795168872 +0600
+@@ -56,7 +56,7 @@
+ Usage:
+ bbackupd-config config-dir backup-mode account-num server-hostname working-dir backup-dir [more backup directories]
+
+-config-dir usually /etc/box
++config-dir usually /etc/boxbackup
+ backup-mode is lazy or snapshot
+ lazy mode runs continously, uploading files over a specified age
+ snapshot mode uploads a snapshot of the filesystem when instructed explicitly
+@@ -92,7 +92,7 @@
+ }
+
+ # default locations
+-my $default_config_location = '/etc/box/bbackupd.conf';
++my $default_config_location = '/etc/boxbackup/bbackupd.conf';
+
+ # command line parameters
+ my ($config_dir,$backup_mode,$account_num,$server,$working_dir,@tobackup) = @ARGV;
+@@ -540,7 +540,7 @@
+ more files will be backed up. You want to know about this.
+
+ 6) Start the backup daemon with the command
+- /usr/local/bin/bbackupd$daemon_args
++ /usr/sbin/bbackupd$daemon_args
+ in /etc/rc.local, or your local equivalent.
+ Note that bbackupd must run as root.
+ __E
+@@ -550,7 +550,7 @@
+
+ 7) Set up a cron job to run whenever you want a snapshot of the
+ file system to be taken. Run the command
+- /usr/local/bin/bbackupctl -q$ctl_daemon_args sync
++ /usr/sbin/bbackupctl -q$ctl_daemon_args sync
+ __E
+ }
+ print <<__E;
+diff -ruN boxbackup-0.09.orig/bin/bbstored/bbstored-config boxbackup-0.09/bin/bbstored/bbstored-config
+--- boxbackup-0.09.orig/bin/bbstored/bbstored-config 2005-04-18 15:11:17.600116320 +0600
++++ boxbackup-0.09/bin/bbstored/bbstored-config 2005-04-18 17:40:00.205674096 +0600
+@@ -57,7 +57,7 @@
+ Usage:
+ bbstored-config config-dir server-hostname username [raidfile-config]
+
+-config-dir usually /etc/box
++config-dir usually /etc/boxbackup
+ server-hostname is the hostname used by clients to connect to this server
+ username is the user to run the server under
+ raidfile-config is optional. Use if you have a non-standard raidfile.conf file.
+@@ -83,7 +83,7 @@
+ }
+
+ # default locations
+-my $default_config_location = '/etc/box/bbstored.conf';
++my $default_config_location = '/etc/boxbackup/bbstored.conf';
+
+ # command line parameters
+ my ($config_dir,$server,$username,$raidfile_config) = @ARGV;
+@@ -270,7 +270,7 @@
+ 4) Create accounts with bbstoreaccounts
+
+ 5) Start the backup store daemon with the command
+- /usr/local/bin/bbstored$daemon_args
++ /usr/sbin/bbstored$daemon_args
+ in /etc/rc.local, or your local equivalent.
+
+ ===================================================================
+diff -ruN boxbackup-0.09.orig/infrastructure/BoxPlatform.pm boxbackup-0.09/infrastructure/BoxPlatform.pm
+--- boxbackup-0.09.orig/infrastructure/BoxPlatform.pm 2005-04-18 15:11:17.581119208 +0600
++++ boxbackup-0.09/infrastructure/BoxPlatform.pm 2005-04-18 16:35:27.793370248 +0600
+@@ -78,7 +78,7 @@
+ close VERSION;
+
+ # where to put the files
+- $install_into_dir = '/usr/local/bin';
++ $install_into_dir = '$1/usr/sbin';
+
+ # if it's Darwin,
+ if($build_os eq 'Darwin')
+diff -ruN boxbackup-0.09.orig/infrastructure/makeparcels.pl boxbackup-0.09/infrastructure/makeparcels.pl
+--- boxbackup-0.09.orig/infrastructure/makeparcels.pl 2005-04-18 15:11:17.581119208 +0600
++++ boxbackup-0.09/infrastructure/makeparcels.pl 2005-04-18 17:52:15.451899680 +0600
+@@ -139,11 +139,11 @@
+ {
+ my $exeext = ($build_os eq 'CYGWIN')?'.exe':'';
+ print MAKE "\t(cd bin/$name; $make_command $release_flag)\n";
+- print MAKE "\tcp release/bin/$name/$name$exeext $dir\n";
++ print MAKE "\tcp -R release/bin/$name/$name$exeext $dir/\n";
+ }
+ elsif ($type eq 'script')
+ {
+- print MAKE "\tcp $name $dir\n";
++ print MAKE "\tcp $name $dir/\n";
+ # remove path from script name
+ $name =~ m~/([^/]+)\Z~;
+ $name = $1;
+@@ -157,13 +157,13 @@
+ chmod 0755,"parcels/scripts/install-$parcel";
+
+ my $root = parcel_root($parcel);
+- print MAKE "\tcp parcels/scripts/install-$parcel $dir\n";
++ print MAKE "\tcp parcels/scripts/install-$parcel $dir/\n";
+ print MAKE "\t(cd parcels; tar cf - $root | gzip -9 - > $root.tgz )\n";
+
+ print MAKE "\n";
+
+ print MAKE "install-$parcel:\n";
+- print MAKE "\t(cd $dir; ./install-$parcel)\n\n";
++ print MAKE "\t(cd $dir; ./install-$parcel \$(DESTDIR) )\n\n";
+ }
+
+ print MAKE <<__E;
+diff -ruN boxbackup-0.09.orig/lib/common/BoxPortsAndFiles.h boxbackup-0.09/lib/common/BoxPortsAndFiles.h
+--- boxbackup-0.09.orig/lib/common/BoxPortsAndFiles.h 2005-04-18 15:11:17.345155080 +0600
++++ boxbackup-0.09/lib/common/BoxPortsAndFiles.h 2005-04-18 17:40:43.200137944 +0600
+@@ -54,16 +54,16 @@
+
+ // Backup store daemon
+ #define BOX_PORT_BBSTORED (BOX_PORT_BASE+1)
+-#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "/etc/box/bbstored.conf"
++#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "/etc/boxbackup/bbstored.conf"
+ // directory within the RAIDFILE root for the backup store daemon
+ #define BOX_RAIDFILE_ROOT_BBSTORED "backup"
+
+ // Backup client daemon
+-#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "/etc/box/bbackupd.conf"
++#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "/etc/boxbackup/bbackupd.conf"
+
+
+ // RaidFile conf location efault
+-#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "/etc/box/raidfile.conf"
++#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "/etc/boxbackup/raidfile.conf"
+
+
+ #endif // BOXPORTSANDFILES__H
+diff -ruN boxbackup-0.09.orig/lib/raidfile/raidfile-config boxbackup-0.09/lib/raidfile/raidfile-config
+--- boxbackup-0.09.orig/lib/raidfile/raidfile-config 2005-04-18 15:11:17.450139120 +0600
++++ boxbackup-0.09/lib/raidfile/raidfile-config 2005-04-18 17:40:30.723034752 +0600
+@@ -57,7 +57,7 @@
+ Usage:
+ raidfile-config config-dir block-size dir0 [dir1 dir2]
+
+-config-dir usually /etc/box
++config-dir usually /etc/boxbackup
+ block-size must be a power of two, and usually the block or fragment size of your filing system
+ dir0, dir1, dir2 are the directories used as the root of the raid file system
+
+diff -ruN boxbackup-0.09.orig/lib/raidfile/RaidFileController.h boxbackup-0.09/lib/raidfile/RaidFileController.h
+--- boxbackup-0.09.orig/lib/raidfile/RaidFileController.h 2005-04-18 15:11:17.435141400 +0600
++++ boxbackup-0.09/lib/raidfile/RaidFileController.h 2005-04-18 17:40:20.070654160 +0600
+@@ -120,7 +120,7 @@
+ ~RaidFileController();
+
+ public:
+- void Initialise(const char *ConfigFilename = "/etc/box/raidfile.conf");
++ void Initialise(const char *ConfigFilename = "/etc/boxbackup/raidfile.conf");
+ int GetNumDiscSets() {return mSetList.size();}
+
+ // --------------------------------------------------------------------------
diff --git a/app-backup/boxbackup/files/digest-boxbackup-0.09 b/app-backup/boxbackup/files/digest-boxbackup-0.09
new file mode 100644
index 000000000000..caf707621ce5
--- /dev/null
+++ b/app-backup/boxbackup/files/digest-boxbackup-0.09
@@ -0,0 +1,2 @@
+MD5 b4fced539ed72855383f25609de9e6da boxbackup-0.09.tgz 505088
+MD5 2072291536a33e24ecd0a58cffcbf6b8 boxbackup-0.09-solaris.patch.bz2 6814
diff --git a/app-backup/boxbackup/metadata.xml b/app-backup/boxbackup/metadata.xml
new file mode 100644
index 000000000000..d795c141a444
--- /dev/null
+++ b/app-backup/boxbackup/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>app-backup</herd>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>mark@spanbroek.net</email>
+ <name>Mark Spanbroek</name>
+ <description>Original submitter of the ebuild, will help out
+ maintaining if problems arise.</description>
+ </maintainer>
+ <longdescription>An open source, completely automatic on-line backup
+ system for UNIX.</longdescription>
+</pkgmetadata>