summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-07-19 13:09:16 +0000
committerBrian Evans <grknight@gentoo.org>2014-07-19 13:09:16 +0000
commit9ab5e37e71c71a94ff0007e15f69226ee9063646 (patch)
tree35e9dc864c4363145cd716c655f0109db485fb63 /app-backup/cyphertite
parentImprove dependencies (diff)
downloadgentoo-2-9ab5e37e71c71a94ff0007e15f69226ee9063646.tar.gz
gentoo-2-9ab5e37e71c71a94ff0007e15f69226ee9063646.tar.bz2
gentoo-2-9ab5e37e71c71a94ff0007e15f69226ee9063646.zip
Fix build system which wrongly filtered using s/-lssl//g to use s/-lssl //g . This breaks curl linked with non-OpenSSL such as nss and is bad
practice anyway (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'app-backup/cyphertite')
-rw-r--r--app-backup/cyphertite/ChangeLog10
-rw-r--r--app-backup/cyphertite/cyphertite-2.0.2-r3.ebuild (renamed from app-backup/cyphertite/cyphertite-2.0.2-r2.ebuild)2
-rw-r--r--app-backup/cyphertite/files/cyphertite-2.0.2-fix-build.patch18
3 files changed, 22 insertions, 8 deletions
diff --git a/app-backup/cyphertite/ChangeLog b/app-backup/cyphertite/ChangeLog
index a47d9becd7d8..a7f32f8338d7 100644
--- a/app-backup/cyphertite/ChangeLog
+++ b/app-backup/cyphertite/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-backup/cyphertite
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/cyphertite/ChangeLog,v 1.4 2014/07/09 00:23:30 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/cyphertite/ChangeLog,v 1.5 2014/07/19 13:09:15 grknight Exp $
+
+*cyphertite-2.0.2-r3 (19 Jul 2014)
+
+ 19 Jul 2014; Brian Evans <grknight@gentoo.org> +cyphertite-2.0.2-r3.ebuild,
+ -cyphertite-2.0.2-r2.ebuild, files/cyphertite-2.0.2-fix-build.patch:
+ Fix build system which wrongly filtered using s/-lssl//g to use s/-lssl //g .
+ This breaks curl linked with non-OpenSSL such as nss and is bad practice
+ anyway
09 Jul 2014; Brian Evans <grknight@gentoo.org>
files/cyphertite-2.0.2-cflags.patch:
diff --git a/app-backup/cyphertite/cyphertite-2.0.2-r2.ebuild b/app-backup/cyphertite/cyphertite-2.0.2-r3.ebuild
index 938988bb41b2..e9d5ca7a2a42 100644
--- a/app-backup/cyphertite/cyphertite-2.0.2-r2.ebuild
+++ b/app-backup/cyphertite/cyphertite-2.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/cyphertite/cyphertite-2.0.2-r2.ebuild,v 1.1 2014/07/06 20:43:31 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/cyphertite/cyphertite-2.0.2-r3.ebuild,v 1.1 2014/07/19 13:09:15 grknight Exp $
EAPI=5
diff --git a/app-backup/cyphertite/files/cyphertite-2.0.2-fix-build.patch b/app-backup/cyphertite/files/cyphertite-2.0.2-fix-build.patch
index 1862acc79269..452a63038491 100644
--- a/app-backup/cyphertite/files/cyphertite-2.0.2-fix-build.patch
+++ b/app-backup/cyphertite/files/cyphertite-2.0.2-fix-build.patch
@@ -42,8 +42,9 @@ diff -aurNw cyphertite-2.0.2/cyphertite/cyphertite/GNUmakefile cyphertite-2.0.2.
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS
@@ -132,8 +133,9 @@ diff -aurwN cyphertite-2.0.2/cyphertite/examples/ct_archive/GNUmakefile cypherti
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS
@@ -154,8 +156,9 @@ diff -aurwN cyphertite-2.0.2/cyphertite/examples/ct_delete/GNUmakefile cyphertit
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS
@@ -176,8 +179,9 @@ diff -aurwN cyphertite-2.0.2/cyphertite/examples/ct_exists/GNUmakefile cyphertit
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS
@@ -198,8 +202,9 @@ diff -aurwN cyphertite-2.0.2/cyphertite/examples/ct_extract/GNUmakefile cypherti
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS
@@ -220,8 +225,9 @@ diff -aurwN cyphertite-2.0.2/cyphertite/examples/ct_list/GNUmakefile cyphertite-
# curl
-CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --static-libs | \
+- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
+CURL.LDLIBS = $(shell PATH=$(BINDIR):$$PATH curl-config --libs | \
- sed -e 's/-lssl//g' -e 's/-lcrypto//g' -e 's/-lz//g' -e 's/ \+/ /g')
++ sed -e 's/-lssl //g' -e 's/-lcrypto //g' -e 's/-lz //g' -e 's/ \+/ /g')
# Compiler and linker flags.
CPPFLAGS += -DNEED_LIBCLENS