summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-13 04:10:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-13 04:10:06 +0000
commita80999caa293d4f7b572d39fd0bab250e8728661 (patch)
treeb2e97e9870843c64f5620875da9f52125d764666 /app-arch
parentarm/s390/sh stable (Manifest recommit) (diff)
downloadgentoo-2-a80999caa293d4f7b572d39fd0bab250e8728661.tar.gz
gentoo-2-a80999caa293d4f7b572d39fd0bab250e8728661.tar.bz2
gentoo-2-a80999caa293d4f7b572d39fd0bab250e8728661.zip
old
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.5-r12
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.5-r22
-rw-r--r--app-arch/gzip/gzip-1.3.5-r1.ebuild81
-rw-r--r--app-arch/gzip/gzip-1.3.5-r2.ebuild82
4 files changed, 0 insertions, 167 deletions
diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r1 b/app-arch/gzip/files/digest-gzip-1.3.5-r1
deleted file mode 100644
index d9e68f978e4f..000000000000
--- a/app-arch/gzip/files/digest-gzip-1.3.5-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip_1.3.5.orig.tar.gz 331550
-MD5 63d6cf343da210a3740aef2ed583f85d gzip-1.3.5-deb.patch.bz2 9136
diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r2 b/app-arch/gzip/files/digest-gzip-1.3.5-r2
deleted file mode 100644
index d9e68f978e4f..000000000000
--- a/app-arch/gzip/files/digest-gzip-1.3.5-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip_1.3.5.orig.tar.gz 331550
-MD5 63d6cf343da210a3740aef2ed583f85d gzip-1.3.5-deb.patch.bz2 9136
diff --git a/app-arch/gzip/gzip-1.3.5-r1.ebuild b/app-arch/gzip/gzip-1.3.5-r1.ebuild
deleted file mode 100644
index e9cd95daa276..000000000000
--- a/app-arch/gzip/gzip-1.3.5-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r1.ebuild,v 1.11 2004/10/13 23:08:36 lv Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-# This is also available from alpha.gnu.org, but that site has very limited
-# bandwidth and often isn't accessible
-SRC_URI="mirror://debian/pool/main/g/gzip/gzip_${PV}.orig.tar.gz
- mirror://gentoo/${P}-deb.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ~ia64 ~ppc64 ~s390"
-IUSE="nls build static pic"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack gzip_${PV}.orig.tar.gz
- cd ${S}
- epatch ${DISTDIR}/${P}-deb.patch.bz2
-}
-
-src_compile() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf --exec-prefix=/ $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr \
- exec_prefix=${D}/ \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- cd ${D}/bin
-
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- sed -i -e "s:${D}::" ${i} || die
- chmod 755 ${i}
- done
-
- # No need to waste space -- these guys should be links
- # gzcat is equivilant to zcat, but historically zcat
- # was a link to compress.
- rm -f gunzip zcat zcmp zegrep zfgrep
- dosym gzip /bin/gunzip
- dosym gzip /bin/gzcat
- dosym gzip /bin/zcat
- dosym zdiff /bin/zcmp
- dosym zgrep /bin/zegrep
- dosym zgrep /bin/zfgrep
-
- if ! use build
- then
- cd ${D}/usr/share/man/man1
- rm -f gunzip.* zcmp.* zcat.*
- ln -s gzip.1.gz gunzip.1.gz
- ln -s zdiff.1.gz zcmp.1.gz
- ln -s gzip.1.gz zcat.1.gz
- ln -s gzip.1.gz gzcat.1.gz
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
diff --git a/app-arch/gzip/gzip-1.3.5-r2.ebuild b/app-arch/gzip/gzip-1.3.5-r2.ebuild
deleted file mode 100644
index c2ba218fa0e5..000000000000
--- a/app-arch/gzip/gzip-1.3.5-r2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r2.ebuild,v 1.10 2004/11/12 15:04:27 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-# This is also available from alpha.gnu.org, but that site has very limited
-# bandwidth and often isn't accessible
-SRC_URI="mirror://debian/pool/main/g/gzip/gzip_${PV}.orig.tar.gz
- mirror://gentoo/${P}-deb.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build static pic"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack gzip_${PV}.orig.tar.gz
- cd ${S}
- epatch ${DISTDIR}/${P}-deb.patch.bz2
- epatch ${FILESDIR}/gzip-1.3.5-zdiff-tempfile.patch
-}
-
-src_compile() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf --exec-prefix=/ $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr \
- exec_prefix=${D}/ \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- cd ${D}/bin
-
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- sed -i -e "s:${D}::" ${i} || die
- chmod 755 ${i}
- done
-
- # No need to waste space -- these guys should be links
- # gzcat is equivilant to zcat, but historically zcat
- # was a link to compress.
- rm -f gunzip zcat zcmp zegrep zfgrep
- dosym gzip /bin/gunzip
- dosym gzip /bin/gzcat
- dosym gzip /bin/zcat
- dosym zdiff /bin/zcmp
- dosym zgrep /bin/zegrep
- dosym zgrep /bin/zfgrep
-
- if ! use build
- then
- cd ${D}/usr/share/man/man1
- rm -f gunzip.* zcmp.* zcat.*
- ln -s gzip.1.gz gunzip.1.gz
- ln -s zdiff.1.gz zcmp.1.gz
- ln -s gzip.1.gz zcat.1.gz
- ln -s gzip.1.gz gzcat.1.gz
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}