summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-19 16:18:49 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-19 16:18:49 +0000
commit8639bd1b34615f3bfcb14a559b9d2a2a2e63ef9c (patch)
tree5b9ff04420414340ac810cebc84bd31281097fc3 /app-arch
parentUpdate to 1.6.0 final. (diff)
downloadgentoo-2-8639bd1b34615f3bfcb14a559b9d2a2a2e63ef9c.tar.gz
gentoo-2-8639bd1b34615f3bfcb14a559b9d2a2a2e63ef9c.tar.bz2
gentoo-2-8639bd1b34615f3bfcb14a559b9d2a2a2e63ef9c.zip
fix autotools up some more #151874
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/ChangeLog6
-rw-r--r--app-arch/rpm/files/rpm-4.4.6-autotools.patch22
-rw-r--r--app-arch/rpm/rpm-4.4.6-r2.ebuild9
-rw-r--r--app-arch/rpm/rpm-4.4.7.ebuild9
4 files changed, 37 insertions, 9 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 2761ec5aca87..d7e772fe0fcc 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,10 +1,6 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.72 2006/10/19 07:01:22 pva Exp $
-
- 19 Oct 2006; Peter Volkov <pva@gentoo.org> rpm-4.4.6-r2.ebuild,
- rpm-4.4.7.ebuild:
- Forcing automake-1.9. See bug #151874.
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.73 2006/10/19 16:18:49 vapier Exp $
17 Oct 2006; Mike Frysinger <vapier@gentoo.org>
files/rpm-4.4.6-stupidness.patch, files/rpm-4.4.6-with-sqlite.patch,
diff --git a/app-arch/rpm/files/rpm-4.4.6-autotools.patch b/app-arch/rpm/files/rpm-4.4.6-autotools.patch
new file mode 100644
index 000000000000..55fced35fe89
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.4.6-autotools.patch
@@ -0,0 +1,22 @@
+fixup autotool warning:
+
+configure.ac:661: warning: AC_COMPILE_IFELSE was called before AC_GNU_SOURCE
+autoconf/specific.m4:335: AC_GNU_SOURCE is expanded from...
+aclocal.m4:8669: gl_LOCK_BODY is expanded from...
+aclocal.m4:8463: gl_LOCK is expanded from...
+aclocal.m4:609: gt_INTL_SUBDIR_CORE is expanded from...
+aclocal.m4:511: AM_INTL_SUBDIR is expanded from...
+aclocal.m4:387: AM_GNU_GETTEXT is expanded from...
+configure.ac:661: the top level
+configure.ac:661: warning: AC_RUN_IFELSE was called before AC_GNU_SOURCE
+
+--- configure.ac
++++ configure.ac
+@@ -57,6 +57,7 @@
+ AC_PROG_MAKE_SET
+ dnl AC_PROG_RANLIB
+ AC_PROG_YACC
++AC_GNU_SOURCE
+
+ AC_AIX
+ AC_MINIX
diff --git a/app-arch/rpm/rpm-4.4.6-r2.ebuild b/app-arch/rpm/rpm-4.4.6-r2.ebuild
index bf0ca7901559..f4d2aea3ecb0 100644
--- a/app-arch/rpm/rpm-4.4.6-r2.ebuild
+++ b/app-arch/rpm/rpm-4.4.6-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r2.ebuild,v 1.3 2006/10/19 07:01:22 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r2.ebuild,v 1.4 2006/10/19 16:18:49 vapier Exp $
WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.9"
+WANT_AUTOMAKE="latest"
inherit eutils autotools distutils perl-module
DESCRIPTION="Red Hat Package Management Utils"
@@ -37,6 +37,11 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
epatch "${FILESDIR}"/rpm-4.4.6-stupidness.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
+
+ # rpm uses AM_GNU_GETTEXT() but fails to actually
+ # include any of the required gettext files
+ cp /usr/share/gettext/config.rpath . || die
# the following are additional libraries that might be packaged with
# the rpm sources. grep for "test -d" in configure.ac
diff --git a/app-arch/rpm/rpm-4.4.7.ebuild b/app-arch/rpm/rpm-4.4.7.ebuild
index 99e3949c304f..84e49a5a5e4a 100644
--- a/app-arch/rpm/rpm-4.4.7.ebuild
+++ b/app-arch/rpm/rpm-4.4.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7.ebuild,v 1.3 2006/10/19 07:01:22 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7.ebuild,v 1.4 2006/10/19 16:18:49 vapier Exp $
WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.9"
+WANT_AUTOMAKE="latest"
inherit eutils autotools distutils perl-module
DESCRIPTION="Red Hat Package Management Utils"
@@ -37,6 +37,11 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
epatch "${FILESDIR}"/rpm-4.4.7-stupidness.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
+
+ # rpm uses AM_GNU_GETTEXT() but fails to actually
+ # include any of the required gettext files
+ cp /usr/share/gettext/config.rpath . || die
# the following are additional libraries that might be packaged with
# the rpm sources. grep for "test -d" in configure.ac