summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-02 19:52:06 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-02 19:52:06 +0000
commit5daf5143ad1fdbe90f28819cd0a1159389030caf (patch)
tree6150e1dc6837be738ea1654943201a9cbf8babea /app-arch
parentMask www-apps/viewcvs in favor of www-apps/viewvc. (diff)
downloadgentoo-2-5daf5143ad1fdbe90f28819cd0a1159389030caf.tar.gz
gentoo-2-5daf5143ad1fdbe90f28819cd0a1159389030caf.tar.bz2
gentoo-2-5daf5143ad1fdbe90f28819cd0a1159389030caf.zip
Cleanup the build system yet again #200995.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zip/ChangeLog8
-rw-r--r--app-arch/zip/files/digest-zip-2.32-r13
-rw-r--r--app-arch/zip/files/zip-2.32-build.patch89
-rw-r--r--app-arch/zip/zip-2.32-r1.ebuild43
4 files changed, 142 insertions, 1 deletions
diff --git a/app-arch/zip/ChangeLog b/app-arch/zip/ChangeLog
index aaf0b770200f..34f0757b0043 100644
--- a/app-arch/zip/ChangeLog
+++ b/app-arch/zip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/zip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.66 2007/06/13 00:31:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.67 2007/12/02 19:52:06 vapier Exp $
+
+*zip-2.32-r1 (02 Dec 2007)
+
+ 02 Dec 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/zip-2.32-build.patch, +zip-2.32-r1.ebuild:
+ Cleanup the build system yet again #200995.
13 Jun 2007; Mike Frysinger <vapier@gentoo.org> files/zip-2.31-make.patch,
zip-2.32.ebuild:
diff --git a/app-arch/zip/files/digest-zip-2.32-r1 b/app-arch/zip/files/digest-zip-2.32-r1
new file mode 100644
index 000000000000..8b69fc356e59
--- /dev/null
+++ b/app-arch/zip/files/digest-zip-2.32-r1
@@ -0,0 +1,3 @@
+MD5 8a4da4460386e324debe97f3b7fe4d96 zip232.tar.gz 807180
+RMD160 6b9326c8a60bc6bf08825e416140fd0ca8a6a7f1 zip232.tar.gz 807180
+SHA256 d0d3743f732a9baa162f80d0c4567b9c545b41a3385825042113810f2a56eb2f zip232.tar.gz 807180
diff --git a/app-arch/zip/files/zip-2.32-build.patch b/app-arch/zip/files/zip-2.32-build.patch
new file mode 100644
index 000000000000..61a2bae34b3f
--- /dev/null
+++ b/app-arch/zip/files/zip-2.32-build.patch
@@ -0,0 +1,89 @@
+respect build environment settings
+
+--- zip/unix/Makefile
++++ zip/unix/Makefile
+@@ -12,15 +12,15 @@
+
+ list: all
+
+-MAKE = make -f unix/Makefile
++MAKE := $(MAKE) -f unix/Makefile
+ SHELL = /bin/sh
+ LN = ln -s
+
+ # (to use the Gnu compiler, change cc to gcc in CC)
+-CC = cc
++CC ?= gcc
+ BIND = $(CC)
+ AS = $(CC) -c
+-CPP = /lib/cpp
++CPP ?= $(CC)
+ EXE =
+
+ # probably can change this to 'install' if you have it
+@@ -47,7 +47,7 @@
+ # LFLAGS1 flags after output file spec, before obj file list
+ # LFLAGS2 flags after obj file list (libraries, etc)
+ CFLAGS_NOOPT = -I. -DUNIX $(LOCAL_ZIP)
+-CFLAGS = -O2 $(CFLAGS_NOOPT)
++CFLAGS ?= -O2 $(CFLAGS_NOOPT)
+ LFLAGS1 =
+ LFLAGS2 = -s
+
+--- zip/unix/configure
++++ zip/unix/configure
+@@ -13,52 +13,13 @@
+
+ CC=${1-cc}
+-CFLAGS=${2-"-I. -DUNIX"}
+-LFLAGS1=""
++CFLAGS="${2--I. -DUNIX} ${CFLAGS} ${CPPFLAGS}"
++LFLAGS1="${LDFLAGS}"
+ LN="ln -s"
+-echo "Check C compiler type (optimization option)"
+-cat > conftest.c << _EOF_
+-int main()
+-{
+-#ifndef __SUNPRO_C
+- bad code
+-#endif
+- return 0;
+-}
+-_EOF_
+-$CC $CFLAGS -c conftest.c > /dev/null 2>/dev/null
+-if test $? -eq 0; then
+- echo ' Sun C (-xO3)'
+- CFLAGS="${CFLAGS} -xO3"
+-else
+- cat > conftest.c << _EOF_
+-int main()
+-{
+-#ifndef __DECC
+- bad code
+-#endif
+- return 0;
+-}
+-_EOF_
+- $CC $CFLAGS -c conftest.c > /dev/null 2>/dev/null
+- if test $? -eq 0; then
+- echo ' DEC C (-O3)'
+- CFLAGS="${CFLAGS} -O3"
+- else
+- echo ' Other (gcc?) (-O2)'
+- CFLAGS="${CFLAGS} -O2"
+- fi
+-fi
+
+ echo Check for the C preprocessor
+ # on SVR4, cc -E does not produce correct assembler files. Need /lib/cpp.
+ CPP="${CC} -E"
+ # solaris as(1) needs -P, maybe others as well ?
+-[ -f /usr/ccs/lib/cpp ] && CPP="/usr/ccs/lib/cpp -P"
+-[ -f /usr/lib/cpp ] && CPP=/usr/lib/cpp
+-[ -f /lib/cpp ] && CPP=/lib/cpp
+-[ -f /usr/bin/cpp ] && CPP=/usr/bin/cpp
+-[ -f /xenix ] && CPP="${CC} -E"
+-[ -f /lynx.os ] && CPP="${CC} -E"
+
+ echo "#include <stdio.h>" > conftest.c
+ $CPP conftest.c >/dev/null 2>/dev/null || CPP="${CC} -E"
diff --git a/app-arch/zip/zip-2.32-r1.ebuild b/app-arch/zip/zip-2.32-r1.ebuild
new file mode 100644
index 000000000000..3ed7e02eacdd
--- /dev/null
+++ b/app-arch/zip/zip-2.32-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.32-r1.ebuild,v 1.1 2007/12/02 19:52:06 vapier Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="Info ZIP (encryption support)"
+HOMEPAGE="http://www.info-zip.org/"
+SRC_URI="ftp://ftp.info-zip.org/pub/infozip/src/zip${PV//.}.tar.gz"
+
+LICENSE="Info-ZIP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/zip-2.3-unix_configure-pic.patch
+ epatch "${FILESDIR}"/${PN}-2.31-exec-stack.patch
+ epatch "${FILESDIR}"/${PN}-2.32-build.patch
+}
+
+src_compile() {
+ tc-export CC CPP
+ use crypt || append-flags -DNO_CRYPT
+ append-lfs-flags
+ emake -f unix/Makefile generic || die
+}
+
+src_install() {
+ dobin zip zipnote zipsplit || die
+ doman man/zip.1
+ dosym zip.1 /usr/share/man/man1/zipnote.1
+ dosym zip.1 /usr/share/man/man1/zipzplit.1
+ if use crypt ; then
+ dobin zipcloak || die
+ dosym zip.1 /usr/share/man/man1/zipcloak.1
+ fi
+ dodoc BUGS CHANGES MANUAL README TODO WHATSNEW WHERE proginfo/*.txt
+}