summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-21 05:15:31 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-21 05:15:31 +0000
commit16d8f67e0d576c7a7663b35c7cdf772dfbdf68ac (patch)
tree01e8c050d0adee44b388e3b23fe66cb7480f5ddd /app-arch
parentKeyword ~amd64-linux/~x86-linux (diff)
downloadgentoo-2-16d8f67e0d576c7a7663b35c7cdf772dfbdf68ac.tar.gz
gentoo-2-16d8f67e0d576c7a7663b35c7cdf772dfbdf68ac.tar.bz2
gentoo-2-16d8f67e0d576c7a7663b35c7cdf772dfbdf68ac.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/ChangeLog9
-rw-r--r--app-arch/gzip/gzip-1.4.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index a3b088aae2f8..3c470c6487c3 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/gzip
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.102 2009/11/05 22:34:43 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.103 2010/01/21 05:15:31 vapier Exp $
+
+*gzip-1.4 (21 Jan 2010)
+
+ 21 Jan 2010; Mike Frysinger <vapier@gentoo.org> +gzip-1.4.ebuild:
+ Version bump.
*gzip-1.3.14 (05 Nov 2009)
diff --git a/app-arch/gzip/gzip-1.4.ebuild b/app-arch/gzip/gzip-1.4.ebuild
new file mode 100644
index 000000000000..10163c48cafa
--- /dev/null
+++ b/app-arch/gzip/gzip-1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.4.ebuild,v 1.1 2010/01/21 05:15:31 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
+ mirror://gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls pic static"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${D}"/bin/ || die
+ sed -e 's:/usr::' -i "${D}"/bin/gunzip || die
+}