summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-11-25 22:39:21 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-11-25 22:39:21 +0000
commit0b8869b61550bc5c862beced5eee1f8f96c7d733 (patch)
tree73de4c8c5d220e1bfd10cad9afafd837301e6a8b /app-arch/unarj/unarj-2.63a-r2.ebuild
parentAdd ~alpha + ~ia64 keywords, bug 134717. (diff)
downloadgentoo-2-0b8869b61550bc5c862beced5eee1f8f96c7d733.tar.gz
gentoo-2-0b8869b61550bc5c862beced5eee1f8f96c7d733.tar.bz2
gentoo-2-0b8869b61550bc5c862beced5eee1f8f96c7d733.zip
Stop Makefile stripping binary, thanks to James Kyte for reporting, bug 143270
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'app-arch/unarj/unarj-2.63a-r2.ebuild')
-rw-r--r--app-arch/unarj/unarj-2.63a-r2.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-arch/unarj/unarj-2.63a-r2.ebuild b/app-arch/unarj/unarj-2.63a-r2.ebuild
index e63d8260d4a1..1991a452753b 100644
--- a/app-arch/unarj/unarj-2.63a-r2.ebuild
+++ b/app-arch/unarj/unarj-2.63a-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unarj/unarj-2.63a-r2.ebuild,v 1.12 2006/05/31 17:26:28 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unarj/unarj-2.63a-r2.ebuild,v 1.13 2006/11/25 22:39:21 masterdriverz Exp $
inherit eutils
@@ -16,16 +16,13 @@ IUSE=""
src_unpack() {
unpack ${A}
cd ${S}
- sed -i "/^CFLAGS/s:-O2:${CFLAGS}:" ${S}/Makefile
+ sed -i "/^CFLAGS/s:-O2:${CFLAGS}:" Makefile
epatch ${FILESDIR}/unarj-2.65-CAN-2004-0947.patch
epatch ${FILESDIR}/unarj-2.65-sanitation.patch
-}
-
-src_compile() {
- emake || die
+ sed -i -e 's@strip unarj@@' Makefile
}
src_install() {
- dobin unarj || die
- dodoc unarj.txt technote.txt readme.txt
+ dobin unarj || die 'dobin failed'
+ dodoc unarj.txt technote.txt readme.txt || die 'dodoc failed'
}