summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-11-21 09:53:37 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-11-21 09:53:37 +0000
commit5d3e675e615dc430073e500f7d22c32de7e76300 (patch)
tree9b532f0ad24043aa1ea455abf330ed2ca577dc04 /app-arch/snappy
parentAdd rdep on app-arch/zip (bug #380495). (diff)
downloadgentoo-2-5d3e675e615dc430073e500f7d22c32de7e76300.tar.gz
gentoo-2-5d3e675e615dc430073e500f7d22c32de7e76300.tar.bz2
gentoo-2-5d3e675e615dc430073e500f7d22c32de7e76300.zip
Bump to 1.0.4, bug 385275
(Portage version: 2.2.0_alpha76/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/ChangeLog7
-rw-r--r--app-arch/snappy/snappy-1.0.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-arch/snappy/ChangeLog b/app-arch/snappy/ChangeLog
index 47ba25502308..bb9bedc42b66 100644
--- a/app-arch/snappy/ChangeLog
+++ b/app-arch/snappy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/snappy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/ChangeLog,v 1.1 2011/06/14 00:37:13 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/ChangeLog,v 1.2 2011/11/21 09:53:37 nirbheek Exp $
+
+*snappy-1.0.4 (21 Nov 2011)
+
+ 21 Nov 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +snappy-1.0.4.ebuild:
+ Bump to 1.0.4, bug 385275
*snappy-1.0.3 (14 Jun 2011)
diff --git a/app-arch/snappy/snappy-1.0.4.ebuild b/app-arch/snappy/snappy-1.0.4.ebuild
new file mode 100644
index 000000000000..6bb71f31a5f4
--- /dev/null
+++ b/app-arch/snappy/snappy-1.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/snappy-1.0.4.ebuild,v 1.1 2011/11/21 09:53:37 nirbheek Exp $
+
+EAPI="4"
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README NEWS format_description.txt"
+
+src_prepare() {
+ default
+ # Avoid automagic lzop and gzip by not checking for it
+ #sed -i -e '/^CHECK_EXT_COMPRESSION_LIB/d' "${S}/configure.ac" || die
+ # Avoid eautoreconf due to the above sed by just removing the expanded lines
+ sed -i -e '15126,15385d' "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove docs installed by snappy itself
+ rm -rf "${ED}/usr/share/doc/snappy" || die
+
+ # Remove la files if we're not installing static libraries
+ if ! use static-libs; then
+ find "${ED}" -iname '*.la' -exec rm -f {} + || die
+ fi
+}