summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 03:01:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 03:01:03 +0000
commit99988e67d872552228d93dde2fc7cbe2696b5e53 (patch)
tree7bb9cb08278827c76de721f6fcc0da7e2825003f /app-arch/dump
parentstable on ia64 (Manifest recommit) (diff)
downloadgentoo-2-99988e67d872552228d93dde2fc7cbe2696b5e53.tar.gz
gentoo-2-99988e67d872552228d93dde2fc7cbe2696b5e53.tar.bz2
gentoo-2-99988e67d872552228d93dde2fc7cbe2696b5e53.zip
dont overwrite rmt from tar #68791
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/ChangeLog6
-rw-r--r--app-arch/dump/dump-0.4.37.ebuild46
2 files changed, 29 insertions, 23 deletions
diff --git a/app-arch/dump/ChangeLog b/app-arch/dump/ChangeLog
index c096ae47cbc2..8d6a67ae85ab 100644
--- a/app-arch/dump/ChangeLog
+++ b/app-arch/dump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/dump
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.33 2004/10/17 10:03:36 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.34 2004/10/26 03:01:03 vapier Exp $
+
+ 25 Oct 2004; Mike Frysinger <vapier@gentoo.org> :
+ Install rmt as 'dump-rmt' so as to not kill the rmt installed by tar. Also
+ stabilize for everyone to clean up #68791 by Peter Gantner.
17 Oct 2004; Dylan Carlson <absinthe@gentoo.org> dump-0.4.37.ebuild:
keywords ~amd64.
diff --git a/app-arch/dump/dump-0.4.37.ebuild b/app-arch/dump/dump-0.4.37.ebuild
index 9b6278f97b75..de557864837d 100644
--- a/app-arch/dump/dump-0.4.37.ebuild
+++ b/app-arch/dump/dump-0.4.37.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.37.ebuild,v 1.2 2004/10/17 10:03:36 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.37.ebuild,v 1.3 2004/10/26 03:01:03 vapier Exp $
MY_P=${P/4./4b}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
-HOMEPAGE="http://dump.sourceforge.net"
-SLOT="0"
LICENSE="BSD"
-KEYWORDS="~x86 ~ppc ~sparc ~ia64 ~alpha ~amd64"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE="readline static"
DEPEND=">=sys-fs/e2fsprogs-1.27
@@ -27,36 +27,38 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- if use readline ; then
- for i in configure.in configure
- do
- sed -i "s:-ltermcap:-lncurses:g" \
- ${i}
- done
- fi
+ sed -i "s:-ltermcap:-lncurses:g" configure || die
}
src_compile() {
- local myconf=""
- use static \
- && myconf="${myconf} --enable-static --enable-staticz" \
- || myconf="${myconf} --enable-shared"
-
econf \
--with-dumpdatespath=/etc/dumpdates \
--with-binowner=root \
--with-bingroup=root \
--enable-largefile \
- `use_enable readline` \
- ${myconf} || die
-
+ $(use_enable static) \
+ $(use_enable static staticz) \
+ $(use_enable readline) \
+ || die
emake || die
}
src_install() {
+ # built on old autotools, no DESTDIR support
einstall MANDIR=${D}/usr/share/man/man8 || die
+ mv "${D}"/usr/sbin/{,dump-}rmt
+ mv "${D}"/usr/share/man/man8/{,dump-}rmt.8
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ cd examples
+ local d=
+ for d in * ; do
+ docinto ${d}
+ dodoc ${d}/*
+ done
+}
- dodoc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README \
- REPORTING-BUGS THANKS TODO
- dodoc -r examples/dump_on_cd
+pkg_postinst() {
+ ewarn "Dump now installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with tar's 'rmt'."
}