summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-14 05:09:28 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-14 05:09:28 +0000
commita6ec2b3087b8ea67d49d55303ed44f07b9d56631 (patch)
treece4106b11fdd6bda414c8a0e21d2d0d7717bcd00 /app-arch/dpkg
parentx86 stable wrt bug #337124 (diff)
downloadgentoo-2-a6ec2b3087b8ea67d49d55303ed44f07b9d56631.tar.gz
gentoo-2-a6ec2b3087b8ea67d49d55303ed44f07b9d56631.tar.bz2
gentoo-2-a6ec2b3087b8ea67d49d55303ed44f07b9d56631.zip
Version bump. Fix 1.15.8.4 test limitation too.
(Portage version: 2.2_rc79/cvs/Linux i686)
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/ChangeLog8
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.4.ebuild4
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.5.ebuild85
3 files changed, 94 insertions, 3 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 670be5f19ce0..f9669400174a 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.138 2010/08/13 15:24:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.139 2010/09/14 05:09:28 jer Exp $
+
+*dpkg-1.15.8.5 (14 Sep 2010)
+
+ 14 Sep 2010; Jeroen Roovers <jer@gentoo.org> dpkg-1.15.8.4.ebuild,
+ +dpkg-1.15.8.5.ebuild:
+ Version bump. Fix 1.15.8.4 test limitation too.
*dpkg-1.15.8.4 (13 Aug 2010)
diff --git a/app-arch/dpkg/dpkg-1.15.8.4.ebuild b/app-arch/dpkg/dpkg-1.15.8.4.ebuild
index 3fc3f119cf08..798bd116cde7 100644
--- a/app-arch/dpkg/dpkg-1.15.8.4.ebuild
+++ b/app-arch/dpkg/dpkg-1.15.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.4.ebuild,v 1.1 2010/08/13 15:24:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.4.ebuild,v 1.2 2010/09/14 05:09:28 jer Exp $
EAPI=3
@@ -42,7 +42,7 @@ src_prepare() {
# On every version bump, update the version manually after establishing
# which tests fail (bug #310847)
- if [[ "${PV}" = "1.15.8.3" ]]; then
+ if [[ "${PV}" = "1.15.8.4" ]]; then
sed -i scripts/Makefile.am -e '/850_Dpkg_Compression.t/d' \
|| die "sed failed"
fi
diff --git a/app-arch/dpkg/dpkg-1.15.8.5.ebuild b/app-arch/dpkg/dpkg-1.15.8.5.ebuild
new file mode 100644
index 000000000000..c445c5447b03
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.15.8.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.5.ebuild,v 1.1 2010/09/14 05:09:28 jer Exp $
+
+EAPI=3
+
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="bzip2 dselect nls test unicode zlib"
+
+LANGS="sv de es ja fr hu pl ru"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( app-text/po4a )
+ test? ( dev-perl/Test-Pod dev-perl/IO-String )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
+
+ # don't mess with linker optimisation, respect user's flags (don't break!)
+ sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # On every version bump, update the version manually after establishing
+ # which tests fail (bug #310847)
+ if [[ "${PV}" = "1.15.8.5" ]]; then
+ sed -i scripts/Makefile.am -e '/850_Dpkg_Compression.t/d' \
+ || die "sed failed"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ if use nls; then
+ myconf="--enable-nls $(use_with dselect)"
+ else
+ if use dselect; then
+ elog "Building dselect requires USE=nls - disabling USE=dselect..."
+ fi
+ myconf="--disable-nls --without-dselect"
+ fi
+ econf \
+ ${myconf} \
+ $(use_with bzip2 bz2) \
+ $(use_enable unicode) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --without-selinux \
+ --without-start-stop-daemon
+}
+
+src_install() {
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ LINGUAS=none
+ fi
+
+ emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
+ rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}