summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-08-20 20:11:34 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-08-20 20:11:34 +0000
commitb2050d96aacb67a38f319c5ac223ee18531b046e (patch)
tree606ee59ecd8ee374eeaf0b215d37af3288ad2885 /app-admin
parentMake ffcall compile/generate shared libraries too. Thanks PaX Team in bug #1... (diff)
downloadgentoo-2-b2050d96aacb67a38f319c5ac223ee18531b046e.tar.gz
gentoo-2-b2050d96aacb67a38f319c5ac223ee18531b046e.tar.bz2
gentoo-2-b2050d96aacb67a38f319c5ac223ee18531b046e.zip
Fix compile warnings; bug #188923
(Portage version: 2.1.3.6)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gamin/ChangeLog6
-rw-r--r--app-admin/gamin/files/gamin-0.1.9-compile-warnings.patch22
-rw-r--r--app-admin/gamin/gamin-0.1.9.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index 44f25809773a..2138d25aae7d 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/gamin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.69 2007/08/07 16:41:16 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.70 2007/08/20 20:11:34 dang Exp $
+
+ 20 Aug 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/gamin-0.1.9-compile-warnings.patch, gamin-0.1.9.ebuild:
+ Fix compile warnings; bug #188923
07 Aug 2007; Roy Marples <uberlord@gentoo.org>
+files/gamin-0.1.9-freebsd.patch, gamin-0.1.9.ebuild:
diff --git a/app-admin/gamin/files/gamin-0.1.9-compile-warnings.patch b/app-admin/gamin/files/gamin-0.1.9-compile-warnings.patch
new file mode 100644
index 000000000000..d3e0931391a7
--- /dev/null
+++ b/app-admin/gamin/files/gamin-0.1.9-compile-warnings.patch
@@ -0,0 +1,22 @@
+--- gamin-0.1.9/lib/gam_error.h.1 2007-08-15 01:09:13.000000000 +0200
++++ gamin-0.1.9/lib/gam_error.h 2007-08-15 01:09:27.000000000 +0200
+@@ -47,6 +47,9 @@
+
+ int gam_errno(void);
+
++void gam_error_init(void);
++void gam_error_check(void);
++
+ #ifdef GAM_DEBUG_ENABLED
+
+ #ifdef GAMIN_DEBUG_API
+@@ -70,9 +73,6 @@
+ const char* format, ...);
+ #define GAM_DEBUG if (gam_debug_active) gam_debug
+
+-void gam_error_init(void);
+-void gam_error_check(void);
+-
+ #else
+ /*
+ * no debug, redefine the macro empty content
diff --git a/app-admin/gamin/gamin-0.1.9.ebuild b/app-admin/gamin/gamin-0.1.9.ebuild
index 851212cda49b..c2cab3e9b9bd 100644
--- a/app-admin/gamin/gamin-0.1.9.ebuild
+++ b/app-admin/gamin/gamin-0.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.9.ebuild,v 1.3 2007/08/07 16:41:16 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.9.ebuild,v 1.4 2007/08/20 20:11:34 dang Exp $
inherit autotools eutils libtool
@@ -22,8 +22,10 @@ PROVIDE="virtual/fam"
src_unpack() {
unpack ${A}
-
cd ${S}
+
+ # Fix compile warnings; bug #188923
+ epatch "${FILESDIR}"/${P}-compile-warnings.patch
epatch "${FILESDIR}/${P}-user-cflags.patch"
epatch "${FILESDIR}/${P}-freebsd.patch"