summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:59:10 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:59:10 +0000
commit92d82001804e5ed444a6b97258071ac4111762ff (patch)
tree733388a9bc5db9574534ab52c33c73315b46d59a /app-admin
parentFixed FHS issue (diff)
downloadgentoo-2-92d82001804e5ed444a6b97258071ac4111762ff.tar.gz
gentoo-2-92d82001804e5ed444a6b97258071ac4111762ff.tar.bz2
gentoo-2-92d82001804e5ed444a6b97258071ac4111762ff.zip
Initial import.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/tmpwatch/ChangeLog8
-rw-r--r--app-admin/tmpwatch/files/digest-tmpwatch-2.8.41
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.8.4.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/ChangeLog b/app-admin/tmpwatch/ChangeLog
new file mode 100644
index 000000000000..d665cc340809
--- /dev/null
+++ b/app-admin/tmpwatch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/tmpwatch
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.1 2002/11/08 13:59:10 aliz Exp $
+
+tmpwatch-2.8.4 (08 Nov 2002)
+
+ 08 Nov 2002; Daniel Ahlberg <aliz@gentooorg> :
+ Initial import. Ebuild contributed by Cory Visi <cory@visi.name> in #9817.
diff --git a/app-admin/tmpwatch/files/digest-tmpwatch-2.8.4 b/app-admin/tmpwatch/files/digest-tmpwatch-2.8.4
new file mode 100644
index 000000000000..602fb73d5c80
--- /dev/null
+++ b/app-admin/tmpwatch/files/digest-tmpwatch-2.8.4
@@ -0,0 +1 @@
+MD5 79454f3fd1f6d86e6562ebef64b7a0df tmpwatch-2.8.4-4.src.rpm 20101
diff --git a/app-admin/tmpwatch/tmpwatch-2.8.4.ebuild b/app-admin/tmpwatch/tmpwatch-2.8.4.ebuild
new file mode 100644
index 000000000000..c566a4e2622e
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.8.4.ebuild,v 1.1 2002/11/08 13:59:10 aliz Exp $
+
+RPM_V="4"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility recursively searches through specified directories and removes files which have not been accessed in a specified period of time."
+SRC_URI="ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/${P}-${RPM_V}.src.rpm"
+HOMEPAGE="ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ app-arch/rpm2targz"
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpm2targz ${DISTDIR}/${P}-${RPM_V}.src.rpm
+ tar zxf ${P}-${RPM_V}.src.tar.gz
+ tar zxf ${P}.tar.gz
+
+ cd ${S}
+ sed "s/..RPM_OPT_FLAGS./${CFLAGS}/" \
+ < Makefile > Makefile.new
+ mv -f Makefile.new Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ preplib /usr
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+}