summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 20:53:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 20:53:43 +0000
commit33de2120701b7ed7bc22c35dbdf26746f9c1e430 (patch)
treeb0713fcefb9feffaca773738c5fbcd54e3a8faeb /app-admin
parentstable x86, bug 280072 (diff)
downloadgentoo-2-33de2120701b7ed7bc22c35dbdf26746f9c1e430.tar.gz
gentoo-2-33de2120701b7ed7bc22c35dbdf26746f9c1e430.tar.bz2
gentoo-2-33de2120701b7ed7bc22c35dbdf26746f9c1e430.zip
Version bump (bug #279915).
(Portage version: 13900-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-python/ChangeLog8
-rw-r--r--app-admin/eselect-python/eselect-python-20090804.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index fbd4ca410d85..b815ab60d29a 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.33 2009/08/03 15:07:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.34 2009/08/04 20:53:43 arfrever Exp $
+
+*eselect-python-20090804 (04 Aug 2009)
+
+ 04 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +eselect-python-20090804.ebuild:
+ Version bump (bug #279915).
03 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org>
eselect-python-20090801.ebuild:
diff --git a/app-admin/eselect-python/eselect-python-20090804.ebuild b/app-admin/eselect-python/eselect-python-20090804.ebuild
new file mode 100644
index 000000000000..9bcc5d36f348
--- /dev/null
+++ b/app-admin/eselect-python/eselect-python-20090804.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090804.ebuild,v 1.1 2009/08/04 20:53:43 arfrever Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Manages multiple Python versions"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-1.0.2"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o python-wrapper python.c || die "Building of python wrapper failed"
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+
+ dobin python-wrapper || die "dobin python-wrapper failed"
+
+ insinto /usr/share/eselect/modules
+ doins python.eselect || die "doins python.eselect failed"
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-20090804"; then
+ run_eselect_python_update="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ "${run_eselect_python_update}" == "1" ]]; then
+ ebegin "Running \`eselect python update\`"
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eend "$?"
+ fi
+}