summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-09 11:55:48 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-09 11:55:48 +0000
commite2fa075eb2500584e7acabbcb162dbad15ab9418 (patch)
tree74b024948e2eec4d7e5bc01a5adc3036fe048bae /app-admin/webmin
parentVersion bumped. (diff)
downloadgentoo-2-e2fa075eb2500584e7acabbcb162dbad15ab9418.tar.gz
gentoo-2-e2fa075eb2500584e7acabbcb162dbad15ab9418.tar.bz2
gentoo-2-e2fa075eb2500584e7acabbcb162dbad15ab9418.zip
Version bumped.
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog7
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.1201
-rw-r--r--app-admin/webmin/webmin-1.120.ebuild75
4 files changed, 84 insertions, 3 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index a6ea18d47ea9..1bdf1dc944cc 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webmin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.27 2003/10/28 01:05:44 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.28 2003/11/09 11:55:42 mholzer Exp $
+
+*webmin-1.120 (05 Nov 2003)
+
+ 05 Nov 2003; Martin Holzer <mholzer@gentoo.org> webmin-1.120.ebuild:
+ Version bumped.
27 Oct 2003; Brad House <brad_mssw@gentoo.org> webmin-1.110.ebuild:
add ~amd64 flag
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 431417568642..f5d2b1db7e49 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,7 +1,7 @@
-MD5 379d3c865fe10fb960cd1f3f0bfade7f ChangeLog 4486
+MD5 953a671dcb52845b87f48d832e8276c8 ChangeLog 4603
MD5 85e44244d64f3c9d6c9633fcc8d97d76 webmin-1.080.ebuild 1763
MD5 22fd790cb463b3fb55e6a3343e07cd20 webmin-1.110.ebuild 1865
-MD5 71912b9c58131f161914e2cc7fd12fe8 webmin-1.120.ebuild 1901
+MD5 4b168c5132365cfb0035fecb1b374728 webmin-1.120.ebuild 1854
MD5 7fdd3ae59bfbac3959bdc75e2b40e3dc webmin-1.100-r1.ebuild 1933
MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
MD5 7519cb946bf13c469d0e6ae31afd9e1a files/digest-webmin-1.120 65
diff --git a/app-admin/webmin/files/digest-webmin-1.120 b/app-admin/webmin/files/digest-webmin-1.120
new file mode 100644
index 000000000000..0d17991b9c91
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.120
@@ -0,0 +1 @@
+MD5 fec3e5e92fc9516c9acef955b7a2a078 webmin-1.120.tar.gz 6783375
diff --git a/app-admin/webmin/webmin-1.120.ebuild b/app-admin/webmin/webmin-1.120.ebuild
new file mode 100644
index 000000000000..1e08aa2e4a9a
--- /dev/null
+++ b/app-admin/webmin/webmin-1.120.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.120.ebuild,v 1.1 2003/11/09 11:55:42 mholzer Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+ use ssl sed -i 's:ssl=$ssl:ssl=1:' setup.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}
+
+pkg_prerm() {
+ webmin stop
+}