summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-13 17:47:39 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-13 17:47:39 +0000
commit66bb4548d6eb536dd020ac50723aa3ba284524dd (patch)
tree504ebb869d2d57eb62c3649a2f1b4f8c3425a72b /app-admin/webmin
parentVersion bumped. (diff)
downloadgentoo-2-66bb4548d6eb536dd020ac50723aa3ba284524dd.tar.gz
gentoo-2-66bb4548d6eb536dd020ac50723aa3ba284524dd.tar.bz2
gentoo-2-66bb4548d6eb536dd020ac50723aa3ba284524dd.zip
Version bumped.
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog7
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.0901
-rw-r--r--app-admin/webmin/webmin-1.090.ebuild72
4 files changed, 81 insertions, 3 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 8c9bd77abc9b..887ce7f5d49d 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webmin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.18 2003/04/13 15:02:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.19 2003/05/13 17:47:07 mholzer Exp $
+
+*webmin-1.090 (13 May 2003)
+
+ 13 May 2003; Martin Holzer <mholzer@gentoo.org> webmin-1.090.ebuild:
+ Version bumped.
*webmin-1.080 (13 Apr 2003)
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index da3f199e7fe6..35d704939273 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,5 +1,5 @@
-MD5 c4f4b196e38adc8325cd5e662776a01d ChangeLog 3388
-MD5 0066e4ca724f6e528398fe59b18a0e87 webmin-1.090.ebuild 1766
+MD5 d2f8249e888f4a2ab16461570ff2919a ChangeLog 3507
+MD5 e9556c48a920ea1bd5777eb268ac9283 webmin-1.090.ebuild 1766
MD5 35394441f81a8321971fa6056d0737ea webmin-1.080.ebuild 1763
MD5 546b4c597e554fcbfa4b61686affcdcc files/digest-webmin-1.090 65
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
diff --git a/app-admin/webmin/files/digest-webmin-1.090 b/app-admin/webmin/files/digest-webmin-1.090
new file mode 100644
index 000000000000..b87dc7427f85
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.090
@@ -0,0 +1 @@
+MD5 ad9cc428a3e5154aa43c0b19bf722f51 webmin-1.090.tar.gz 6392798
diff --git a/app-admin/webmin/webmin-1.090.ebuild b/app-admin/webmin/webmin-1.090.ebuild
new file mode 100644
index 000000000000..c3e84e711fc2
--- /dev/null
+++ b/app-admin/webmin/webmin-1.090.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.090.ebuild,v 1.1 2003/05/13 17:47:07 mholzer Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}