summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-16 09:27:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-16 09:27:13 +0000
commit345f17ae25c165777d0eae6a3a4a11a8d7489e78 (patch)
treee3d3566d08086e9a162a1724820deb4c0c095946 /app-admin/webmin
parentfixed wrong syntax in the redhat-artwork-mask (diff)
downloadgentoo-2-345f17ae25c165777d0eae6a3a4a11a8d7489e78.tar.gz
gentoo-2-345f17ae25c165777d0eae6a3a4a11a8d7489e78.tar.bz2
gentoo-2-345f17ae25c165777d0eae6a3a4a11a8d7489e78.zip
version bump
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog9
-rw-r--r--app-admin/webmin/files/digest-webmin-1.0501
-rw-r--r--app-admin/webmin/webmin-1.050.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 1533b4212a3e..1ee5fbc06060 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webmin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.8 2002/11/11 06:59:17 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.9 2002/12/16 09:27:13 seemant Exp $
+
+*webmin-1.050 (16 Dec 2002)
+
+ 16 Dec 2002; Seemant Kulleen <seemant@gentoo.org> webmin-1.050.ebuild
+ files/digest-webmin-1.050 :
+
+ Version bump.
*webmin-1.030 (07 Nov 2002)
diff --git a/app-admin/webmin/files/digest-webmin-1.050 b/app-admin/webmin/files/digest-webmin-1.050
new file mode 100644
index 000000000000..26fed42648d4
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.050
@@ -0,0 +1 @@
+MD5 b65d49925cf1be5ef73bec3ae2f30a8f webmin-1.050.tar.gz 5700879
diff --git a/app-admin/webmin/webmin-1.050.ebuild b/app-admin/webmin/webmin-1.050.ebuild
new file mode 100644
index 000000000000..7d89be47bd17
--- /dev/null
+++ b/app-admin/webmin/webmin-1.050.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.050.ebuild,v 1.1 2002/12/16 09:27:13 seemant Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="http://www.webmin.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ~ppc"
+
+DEPEND="sys-devel/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}