summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-08-09 12:31:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-08-09 12:31:06 +0000
commit39583e6ad88dc93dad949662d7e0453613e50eab (patch)
tree9ccd01d7c341c50d6fa620229865937047e8f9ac /app-admin/paxtest
parentRemove KDE 4.3.x support from deps. (diff)
downloadgentoo-2-39583e6ad88dc93dad949662d7e0453613e50eab.tar.gz
gentoo-2-39583e6ad88dc93dad949662d7e0453613e50eab.tar.bz2
gentoo-2-39583e6ad88dc93dad949662d7e0453613e50eab.zip
Version bump to 0.9.9. See Bugs #322413 and #331599
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/ChangeLog8
-rw-r--r--app-admin/paxtest/files/paxtest-0.9.9-Makefile.patch58
-rw-r--r--app-admin/paxtest/metadata.xml34
-rw-r--r--app-admin/paxtest/paxtest-0.9.9.ebuild81
4 files changed, 163 insertions, 18 deletions
diff --git a/app-admin/paxtest/ChangeLog b/app-admin/paxtest/ChangeLog
index 5a052b0f80ff..979eb148aacf 100644
--- a/app-admin/paxtest/ChangeLog
+++ b/app-admin/paxtest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/paxtest
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.36 2010/07/27 02:11:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.37 2010/08/09 12:31:06 blueness Exp $
+
+*paxtest-0.9.9 (09 Aug 2010)
+
+ 09 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
+ +paxtest-0.9.9.ebuild, +files/paxtest-0.9.9-Makefile.patch, metadata.xml:
+ Version bump to 0.9.9. See Bugs #322413 and #331599
27 Jul 2010; Jeroen Roovers <jer@gentoo.org> paxtest-0.9.6.ebuild:
Stable for HPPA too.
diff --git a/app-admin/paxtest/files/paxtest-0.9.9-Makefile.patch b/app-admin/paxtest/files/paxtest-0.9.9-Makefile.patch
new file mode 100644
index 000000000000..ebf46999f1e8
--- /dev/null
+++ b/app-admin/paxtest/files/paxtest-0.9.9-Makefile.patch
@@ -0,0 +1,58 @@
+diff -Naur paxtest-0.9.9.orig/Makefile paxtest-0.9.9/Makefile
+--- paxtest-0.9.9.orig/Makefile 2010-02-22 18:47:19.000000000 -0500
++++ paxtest-0.9.9/Makefile 2010-08-09 07:50:53.000000000 -0400
+@@ -52,11 +52,13 @@
+ endif
+
+ # for some reason the .c files need it, else GNU_STACK=RWE
+-OPT_FLAGS := -O2 $(ASFLAGS)
++# Gentoo's CFLAGS should be honored
++OPT_FLAGS := $(CFLAGS) $(ASFLAGS)
+ PTHREAD := -lpthread
+ # define stripping of binaries/libs here, or set these on make's commandline,
+ # else you'll loose the chpax flags!
+-LDFLAGS :=
++# Gentoo's LDFLAGS should be honored
++LDFLAGS := $(LDFLAGS)
+ SHLDFLAGS :=
+ ifndef RUNDIR
+ RUNDIR := .
+@@ -136,7 +138,7 @@
+
+ $(EXEC_TESTS) $(MPROT_TESTS): body.o
+ $(CC) $(CFLAGS) -o $@.o -c $@.c
+- $(CC) $(LDFLAGS) $(PTHREAD) -o $@ $< $@.o
++ $(CC) $(LDFLAGS) -o $@ $< $@.o $(PTHREAD)
+
+ $(RAND_TESTS): randbody.o
+ $(CC) $(CFLAGS) -o $@.o -c $@.c
+@@ -185,7 +187,7 @@
+
+ $(MPROTSH_TESTS): body.o shlibtest.so
+ $(CC) $(CFLAGS) -o $@.o -c $@.c
+- $(CC) $(LDFLAGS) $(DL) $(PTHREAD) -o $@ $@.o $^
++ $(CC) $(LDFLAGS) -o $@ $@.o $^ $(DL) $(PTHREAD)
+
+ # used for RANDEXEC'd binaries
+ retbody.o: body.c
+@@ -194,12 +196,12 @@
+ # build as ET_EXEC (recommended by PaX Team, not really a requirement)
+ $(RET_TESTS): retbody.o
+ $(CC) $(CFLAGS) $(CC_ETEXEC) -o $@.o -c $@.c
+- $(CC) $(LDFLAGS) $(LD_ETEXEC) $(PTHREAD) -o $@ $< $@.o
++ $(CC) $(LDFLAGS) $(LD_ETEXEC) -o $@ $< $@.o $(PTHREAD)
+
+ # build as ET_EXEC (not in Adamantix's Makefile)
+ $(RETX_TESTS): retbody.o
+ $(CC) $(CFLAGS) $(CC_ETEXEC) -o $@.o -c $@.c
+- $(CC) $(LDFLAGS) $(LD_ETEXEC) $(PTHREAD) -o $@ $< $@.o
++ $(CC) $(LDFLAGS) $(LD_ETEXEC) -o $@ $< $@.o $(PTHREAD)
+ -$(PAXBIN) -C $@
+ $(PAXBIN) -SPXM $@
+
+@@ -212,4 +214,4 @@
+ $(CC) $(SHLDFLAGS) -shared -o $@ $<
+
+ $(SHLIB_TESTS): body.o $(SHLIBS) shlibbss.o shlibdata.o
+- $(CC) $(LDFLAGS) $(PTHREAD) -o $@ body.o $@.o $(SHLIBS) $(DL)
++ $(CC) $(LDFLAGS) -o $@ body.o $@.o $(SHLIBS) $(DL) $(PTHREAD)
diff --git a/app-admin/paxtest/metadata.xml b/app-admin/paxtest/metadata.xml
index da080aca94df..04475d3958f3 100644
--- a/app-admin/paxtest/metadata.xml
+++ b/app-admin/paxtest/metadata.xml
@@ -3,23 +3,23 @@
<pkgmetadata>
<herd>hardened</herd>
<maintainer>
- <email>solar@gentoo.org</email>
+ <email>blueness@gentoo.org</email>
<description>Primary Maintainer</description>
</maintainer>
-<longdescription>Test suite for the PaX kernel patch
- PaX is a Linux kernel patch which adds much stricter control on how memory
- is being used by applications. A normal Linux kernel leaves the control to the
- application and does not implement any enforcement. Especially buffer overflow
- attacks benefit from the absense of kernel enforced memory control. PaX tries
- to do its best to enforce this control of memory used by applications, thereby
- making it harder to succesfully exploit buffer overflows.
- .
- Furthermore, it adds several randomisations, which also make it harder for
- buffer overflows to succeed.
- .
- The test programs test all this functionality, but not all PaX functionality
- is covered.
- .
- For more information about PaX, see http://pageexec.virtualave.net/.
-</longdescription>
+ <longdescription>Test suite for the PaX kernel patch
+ PaX is a Linux kernel patch which adds much stricter control on how memory
+ is being used by applications. A normal Linux kernel leaves the control to the
+ application and does not implement any enforcement. Especially buffer overflow
+ attacks benefit from the absense of kernel enforced memory control. PaX tries
+ to do its best to enforce this control of memory used by applications, thereby
+ making it harder to succesfully exploit buffer overflows.
+
+ Furthermore, it adds several randomisations, which also make it harder for
+ buffer overflows to succeed.
+
+ The test programs test all this functionality, but not all PaX functionality
+ is covered.
+
+ For more information about PaX, see http://pageexec.virtualave.net/.
+ </longdescription>
</pkgmetadata>
diff --git a/app-admin/paxtest/paxtest-0.9.9.ebuild b/app-admin/paxtest/paxtest-0.9.9.ebuild
new file mode 100644
index 000000000000..2788056e52e7
--- /dev/null
+++ b/app-admin/paxtest/paxtest-0.9.9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.9.ebuild,v 1.1 2010/08/09 12:31:06 blueness Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="PaX regression test suite"
+HOMEPAGE="http://pax.grsecurity.net"
+SRC_URI="http://grsecurity.net/~spender/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/chpax-0.7
+ sys-apps/paxctl"
+
+# EI_PAX flags are not strip safe.
+RESTRICT="strip"
+
+QA_EXECSTACK="usr/bin/${PN}
+ usr/$(get_libdir)/${PN}/getamap
+ usr/$(get_libdir)/${PN}/shlibtest2.so
+ usr/$(get_libdir)/${PN}/execheap
+ usr/$(get_libdir)/${PN}/mprotstack
+ usr/$(get_libdir)/${PN}/mprotdata
+ usr/$(get_libdir)/${PN}/mprotheap
+ usr/$(get_libdir)/${PN}/randshlib
+ usr/$(get_libdir)/${PN}/randmain1
+ usr/$(get_libdir)/${PN}/getshlib
+ usr/$(get_libdir)/${PN}/randheap2
+ usr/$(get_libdir)/${PN}/rettofunc2x
+ usr/$(get_libdir)/${PN}/shlibdata
+ usr/$(get_libdir)/${PN}/shlibbss
+ usr/$(get_libdir)/${PN}/getmain1
+ usr/$(get_libdir)/${PN}/execdata
+ usr/$(get_libdir)/${PN}/execstack
+ usr/$(get_libdir)/${PN}/rettofunc2
+ usr/$(get_libdir)/${PN}/mprotshdata
+ usr/$(get_libdir)/${PN}/getstack1
+ usr/$(get_libdir)/${PN}/randamap
+ usr/$(get_libdir)/${PN}/rettofunc1x
+ usr/$(get_libdir)/${PN}/getheap2
+ usr/$(get_libdir)/${PN}/getheap1
+ usr/$(get_libdir)/${PN}/randheap1
+ usr/$(get_libdir)/${PN}/getstack2
+ usr/$(get_libdir)/${PN}/getmain2
+ usr/$(get_libdir)/${PN}/rettofunc1
+ usr/$(get_libdir)/${PN}/randstack2
+ usr/$(get_libdir)/${PN}/mprotshbss
+ usr/$(get_libdir)/${PN}/randstack1
+ usr/$(get_libdir)/${PN}/mprotanon
+ usr/$(get_libdir)/${PN}/randmain2
+ usr/$(get_libdir)/${PN}/writetext
+ usr/$(get_libdir)/${PN}/mprotbss
+ usr/$(get_libdir)/${PN}/anonmap
+ usr/$(get_libdir)/${PN}/execbss
+ usr/$(get_libdir)/${PN}/shlibtest.so"
+
+src_prepare() {
+ mv Makefile.psm Makefile
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
+ sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
+}
+
+src_compile() {
+ emake RUNDIR=/usr/$(get_libdir)/paxtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install || die
+
+ newman debian/manpage.1.ex paxtest.1 || die
+ dodoc ChangeLog README || die
+}