summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-10-05 20:41:49 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-10-05 20:41:49 +0000
commit4f57c2cd267a9b50d4df8d79fb3e81e9d258342f (patch)
treef8b5add0754d3e186c6b6062524c6b5d9af3c3ff /app-admin/packagekit-base
parentRemoved unusable version (diff)
downloadgentoo-2-4f57c2cd267a9b50d4df8d79fb3e81e9d258342f.tar.gz
gentoo-2-4f57c2cd267a9b50d4df8d79fb3e81e9d258342f.tar.bz2
gentoo-2-4f57c2cd267a9b50d4df8d79fb3e81e9d258342f.zip
revision bump, add upstream patch
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/packagekit-base')
-rw-r--r--app-admin/packagekit-base/ChangeLog9
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch94
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild (renamed from app-admin/packagekit-base/packagekit-base-0.6.18.ebuild)3
3 files changed, 104 insertions, 2 deletions
diff --git a/app-admin/packagekit-base/ChangeLog b/app-admin/packagekit-base/ChangeLog
index 040d9b287724..995d2247ccd1 100644
--- a/app-admin/packagekit-base/ChangeLog
+++ b/app-admin/packagekit-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/packagekit-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/ChangeLog,v 1.6 2011/09/05 21:03:22 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/ChangeLog,v 1.7 2011/10/05 20:41:49 lxnay Exp $
+
+*packagekit-base-0.6.18-r1 (05 Oct 2011)
+
+ 05 Oct 2011; Fabio Erculiani <lxnay@gentoo.org>
+ -packagekit-base-0.6.18.ebuild, +packagekit-base-0.6.18-r1.ebuild,
+ +files/packagekit-base-entropy-add-forward-compatibility.patch:
+ revision bump, add upstream patch
05 Sep 2011; Fabio Erculiani <lxnay@gentoo.org>
packagekit-base-0.6.18.ebuild:
diff --git a/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch b/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch
new file mode 100644
index 000000000000..354fca6fbcbc
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch
@@ -0,0 +1,94 @@
+commit d8c13d8c3e875bf1d87650646cb960a87468ba87
+Author: Fabio Erculiani <lxnay@sabayon.org>
+Date: Wed Oct 5 22:39:30 2011 +0200
+
+ entropy: add forward compatibility with upcoming API changes
+
+diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
+index fe8c609..0c82039 100755
+--- a/backends/entropy/entropyBackend.py
++++ b/backends/entropy/entropyBackend.py
+@@ -64,7 +64,8 @@ from entropy.client.interfaces import Client
+ from entropy.core.settings.base import SystemSettings
+ from entropy.misc import LogFile
+ from entropy.cache import EntropyCacher
+-from entropy.exceptions import SystemDatabaseError
++from entropy.exceptions import SystemDatabaseError, DependenciesNotFound, \
++ DependenciesCollision
+ from entropy.db.exceptions import Error as EntropyRepositoryError
+ try:
+ from entropy.exceptions import DependenciesNotRemovable
+@@ -589,18 +590,32 @@ class PackageKitEntropyMixin(object):
+ if calculate_deps:
+ self.status(STATUS_DEP_RESOLVE)
+ empty_deps, deep_deps = False, False
+- run_queue, removal_queue, status = self._entropy.get_install_queue(
+- matches, empty_deps, deep_deps)
++ try:
++ queue_obj = self._entropy.get_install_queue(
++ matches, empty_deps, deep_deps)
++ if len(queue_obj) == 2:
++ # new api
++ run_queue, removal_queue = queue_obj
++ else:
++ # old api
++ run_queue, removal_queue, status = queue_obj
++ if status == -2:
++ raise DependenciesNotFound(run_queue)
++ elif status == -3:
++ raise DependenciesCollision(run_queue)
++ except DependenciesNotFound as exc:
++ self.error(ERROR_DEP_RESOLUTION_FAILED,
++ "Cannot find the following dependencies: %s" % (
++ ', '.join(sorted(exc.value)),))
++ return
++ except DependenciesCollision:
++ self.error(ERROR_DEP_RESOLUTION_FAILED,
++ "Dependencies collisions, cannot continue")
++ return
++
+ else:
+ run_queue = matches
+ removal_queue = []
+- status = 0
+-
+- if status == -2:
+- self.error(ERROR_DEP_RESOLUTION_FAILED,
+- "Cannot find the following dependencies: %s" % (
+- ', '.join(run_queue),))
+- return
+
+ self.percentage(0)
+ self.status(STATUS_DOWNLOAD)
+@@ -934,12 +949,26 @@ class PackageKitEntropyBackend(PackageKitBaseBackend, PackageKitEntropyMixin):
+
+ empty = False
+ deep = False
+- install, removal, deps_not_f = self._entropy.get_install_queue(matches,
+- empty, deep, recursive = recursive)
+-
+- if deps_not_f == -2:
++ try:
++ queue_obj = self._entropy.get_install_queue(matches,
++ empty, deep, recursive = recursive)
++ if len(queue_obj) == 2:
++ # new api
++ install, removal = queue_obj
++ else:
++ # old api
++ install, removal, status = queue_obj
++ if status == -2:
++ raise DependenciesNotFound(install)
++ elif status == -3:
++ raise DependenciesCollision(install)
++ except DependenciesNotFound as exc:
++ self.error(ERROR_DEP_RESOLUTION_FAILED,
++ "Dependencies not found: %s" % (sorted(exc.value),))
++ return
++ except DependenciesCollision:
+ self.error(ERROR_DEP_RESOLUTION_FAILED,
+- "Dependencies not found: %s" % (sorted(install),))
++ "Dependencies collisions, cannot continue")
+ return
+
+ # transform install into (repo, pkg_id, c_repo) list
diff --git a/app-admin/packagekit-base/packagekit-base-0.6.18.ebuild b/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild
index 3dda846ee4c9..0f6f223b58cc 100644
--- a/app-admin/packagekit-base/packagekit-base-0.6.18.ebuild
+++ b/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.18.ebuild,v 1.3 2011/09/05 21:03:22 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild,v 1.1 2011/10/05 20:41:49 lxnay Exp $
EAPI="3"
@@ -69,6 +69,7 @@ RESTRICT="test" # tests are failing atm
src_prepare() {
epatch "${FILESDIR}/${PN}-0.6.17-entropy-extra-downloads-support.patch"
+ epatch "${FILESDIR}/${PN}-entropy-add-forward-compatibility.patch"
}
src_configure() {