summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-07-22 00:10:10 +0000
committerPeter Johanson <latexer@gentoo.org>2003-07-22 00:10:10 +0000
commit19e6966a216f2559ac5d60b491b5d7219d23cd7c (patch)
tree400f40ae3c3f178a119a29857451af24569511ad /app-admin/osiris/osiris-1.5.2.ebuild
parentNew version into ~x86 (diff)
downloadgentoo-2-19e6966a216f2559ac5d60b491b5d7219d23cd7c.tar.gz
gentoo-2-19e6966a216f2559ac5d60b491b5d7219d23cd7c.tar.bz2
gentoo-2-19e6966a216f2559ac5d60b491b5d7219d23cd7c.zip
New version into ~x86
Diffstat (limited to 'app-admin/osiris/osiris-1.5.2.ebuild')
-rw-r--r--app-admin/osiris/osiris-1.5.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/osiris/osiris-1.5.2.ebuild b/app-admin/osiris/osiris-1.5.2.ebuild
new file mode 100644
index 000000000000..0da577d85f7f
--- /dev/null
+++ b/app-admin/osiris/osiris-1.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/osiris/osiris-1.5.2.ebuild,v 1.1 2003/07/22 00:10:03 latexer Exp $
+
+
+DESCRIPTION="File integrity verification system"
+HOMEPAGE="http://osiris.shmoo.com/"
+SRC_URI="http://osiris.shmoo.com/data/${P}.tar.gz"
+LICENSE="OSIRIS"
+
+SLOT="0"
+KEYWORDS="~x86 -ppc"
+
+IUSE="mysql"
+DEPEND="mysql? ( >=mysql-3.23.54a )"
+
+
+src_compile() {
+
+ # Osiris provides the necessary gdbm source so that gdbm does not
+ # need to be installed to use Osiris. If mysql is set as a USE
+ # variable, Osiris will use mysql instead of gdbm.
+
+ einfo "Osiris uses gdbm by default, and will use MySQL if \"mysql\""
+ einfo "is set as a USE variable; it cannot be configured to use both."
+
+ local myconf
+ use mysql && myconf="${myconf} --enable-module=mysql"
+
+ # The mysql module searches for the mysql.h file in the wrong place
+ # sed line replaces it with the proper path (mysql/mysql.h)
+
+ cp ${S}/src/modules/module_mysql.c ${S}/src/modules/module_mysql.c.old
+ use mysql && sed -e "s:mysql.h:mysql/mysql.h:" \
+ ${S}/src/modules/module_mysql.c.old > ${S}/src/modules/module_mysql.c
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ einstall
+}