summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-12-30 20:06:17 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-12-30 20:06:17 +0000
commit22ee384f9c0985c1e38867f9e2ecfcad17daacce (patch)
treeeed45bcad60523161bc6dc487ed3ef8887a605e5 /app-admin/gps/gps-1.1.0-r1.ebuild
parentmessing with CFLAGS isnt needed (Manifest recommit) (diff)
downloadgentoo-2-22ee384f9c0985c1e38867f9e2ecfcad17daacce.tar.gz
gentoo-2-22ee384f9c0985c1e38867f9e2ecfcad17daacce.tar.bz2
gentoo-2-22ee384f9c0985c1e38867f9e2ecfcad17daacce.zip
several fixes and cleanups including docs dir and compile warnings. Also, should fix bug #71396 by Klaus Kusche <Klaus.Kusche@inode.at>
Diffstat (limited to 'app-admin/gps/gps-1.1.0-r1.ebuild')
-rw-r--r--app-admin/gps/gps-1.1.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/gps/gps-1.1.0-r1.ebuild b/app-admin/gps/gps-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f2dfd6b762d4
--- /dev/null
+++ b/app-admin/gps/gps-1.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gps/gps-1.1.0-r1.ebuild,v 1.1 2004/12/30 20:06:17 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Graphical (GTK+1.2) Process Statistics"
+HOMEPAGE="http://gps.seul.org/"
+SRC_URI="ftp://ftp.seul.org/pub/gps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.bz2
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/rgpsp
+
+ dodoc TODO README* CHANGELOG INSTALL
+
+ doman rgpsp/rgpsp.1
+ doman gps.1x
+
+
+ insinto /etc
+ newins rgpsp/sample.rgpsp.conf rgpsp.conf
+
+ rm -rf ${D}/usr/man ${D}/usr/doc ${D}/etc/rc.d
+ rm -f ${D}/usr/bin/rgpsp
+
+ dosym /usr/bin/rgpsp_linux /usr/bin/rgpsp
+}