summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-07-30 20:50:37 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-07-30 20:50:37 +0000
commit48f855ec9d8feb9590bd3134c9804f7210b72d38 (patch)
tree41fc8b498941c712b0ec0853b0ef6e8ed3c161a9 /app-admin/conky
parentFix dev-haskell/hunit to compile with >=dev-lang/ghc-6.10 (diff)
downloadgentoo-2-48f855ec9d8feb9590bd3134c9804f7210b72d38.tar.gz
gentoo-2-48f855ec9d8feb9590bd3134c9804f7210b72d38.tar.bz2
gentoo-2-48f855ec9d8feb9590bd3134c9804f7210b72d38.zip
Version bump. Remove old.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog10
-rw-r--r--app-admin/conky/conky-1.7.0_rc1.ebuild129
-rw-r--r--app-admin/conky/conky-1.7.1.1-r2.ebuild (renamed from app-admin/conky/conky-1.7.1.1-r1.ebuild)9
-rw-r--r--app-admin/conky/conky-1.7.2_rc2.ebuild (renamed from app-admin/conky/conky-1.7.1.1.ebuild)38
-rw-r--r--app-admin/conky/metadata.xml6
5 files changed, 42 insertions, 150 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 3e1c9e522f6d..ac087cfe561c 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.115 2009/07/19 20:33:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.116 2009/07/30 20:50:37 billie Exp $
+
+*conky-1.7.2_rc2 (30 Jul 2009)
+*conky-1.7.1.1-r2 (30 Jul 2009)
+
+ 30 Jul 2009; Pielmeier Daniel <billie@gentoo.org> -conky-1.7.0_rc1.ebuild,
+ -conky-1.7.1.1.ebuild, -conky-1.7.1.1-r1.ebuild, +conky-1.7.1.1-r2.ebuild,
+ +conky-1.7.2_rc2.ebuild, metadata.xml:
+ Version bump. Remove old.
*conky-1.7.1.1-r1 (19 Jul 2009)
diff --git a/app-admin/conky/conky-1.7.0_rc1.ebuild b/app-admin/conky/conky-1.7.0_rc1.ebuild
deleted file mode 100644
index 235e82654693..000000000000
--- a/app-admin/conky/conky-1.7.0_rc1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.0_rc1.ebuild,v 1.1 2009/03/17 01:22:09 omp Exp $
-
-EAPI="2"
-
-inherit eutils
-# used for epause
-
-DESCRIPTION="An advanced, highly configurable system monitor for X"
-HOMEPAGE="http://conky.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3 BSD LGPL-2.1 MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="audacious bmpx debug hddtemp ibm ipv6 moc mpd nano-syntax nvidia rss truetype vim-syntax wifi X"
-
-DEPEND_COMMON="
- X? (
- x11-libs/libICE
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libSM
- x11-libs/libXrender
- x11-libs/libXdamage
- x11-libs/libXft
- truetype? ( >=media-libs/freetype-2 )
- audacious? ( >=media-sound/audacious-1.5 )
- bmpx? ( media-sound/bmpx
- >=sys-apps/dbus-0.35
- )
- )
- rss? ( dev-libs/libxml2
- net-misc/curl
- )
- wifi? ( net-wireless/wireless-tools )
- nvidia? ( media-video/nvidia-settings )
- !ipv6? ( >=dev-libs/glib-2.0 )"
-RDEPEND="${DEPEND_COMMON}
- hddtemp? ( app-admin/hddtemp )
- vim-syntax? ( || ( app-editors/vim
- app-editors/gvim ) )
- nano-syntax? ( app-editors/nano )"
-DEPEND="
- ${DEPEND_COMMON}
- dev-util/pkgconfig
- X? (
- x11-libs/libXt
- x11-proto/xextproto
- x11-proto/xproto
- )"
-
-src_configure() {
- local myconf
- myconf="--enable-proc-uptime"
- if useq X; then
- myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage --enable-own-window"
- myconf="${myconf} $(use_enable truetype xft)"
- else
- myconf="${myconf} --disable-x11 --disable-double-buffer --disable-xdamage --disable-own-window"
- myconf="${myconf} --disable-xft"
- fi
- econf \
- ${myconf} \
- $(use_enable audacious) \
- $(use_enable bmpx) \
- $(use_enable debug) \
- $(use_enable hddtemp ) \
- $(use_enable ibm) \
- $(use_enable moc) \
- $(use_enable mpd) \
- $(use_enable nvidia) \
- $(use_enable rss) \
- $(use_enable wifi wlan) \
- $(use_enable !ipv6 portmon) || die "econf failed"
-}
-
-src_compile() {
- local mymake
- if useq ipv6 ; then
- ewarn "You have the ipv6 USE flag enabled. Please note that using"
- ewarn "the ipv6 USE flag with Conky disables the port monitor."
- epause
- else
- mymake="MPD_NO_IPV6=noipv6"
- fi
-
- emake ${mymake} || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog AUTHORS README || die
- dohtml doc/docs.html doc/config_settings.html doc/variables.html || die
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${S}"/extras/vim/ftdetect/conkyrc.vim
-
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/extras/vim/syntax/conkyrc.vim
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano/
- doins "${S}"/extras/nano/conky.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "You can find the sample configuration file at"
- elog "/etc/conky/conky.conf. To customize it, copy"
- elog "/etc/conky/conky.conf to ~/.conkyrc and edit"
- elog "it to your liking."
- elog
- elog "For more info on Conky's new features,"
- elog "please look at the README and ChangeLog:"
- elog "/usr/share/doc/${PF}/README.bz2"
- elog "/usr/share/doc/${PF}/ChangeLog.bz2"
- elog "There are also pretty html docs available"
- elog "on Conky's site or in /usr/share/doc/${PF}"
- elog
- elog "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
- elog
- elog "Vim syntax highlighting for conkyrc now enabled with"
- elog "USE=vim-syntax, for Nano with USE=nano-syntax"
- elog
-}
diff --git a/app-admin/conky/conky-1.7.1.1-r1.ebuild b/app-admin/conky/conky-1.7.1.1-r2.ebuild
index ebeba9802970..25683f995d29 100644
--- a/app-admin/conky/conky-1.7.1.1-r1.ebuild
+++ b/app-admin/conky/conky-1.7.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.1.1-r1.ebuild,v 1.1 2009/07/19 20:33:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.1.1-r2.ebuild,v 1.1 2009/07/30 20:50:37 billie Exp $
EAPI="2"
@@ -13,7 +13,8 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3 BSD LGPL-2.1 MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa apcupsd audacious bmpx debug hddtemp imlib lua math moc mpd nano-syntax nvidia openmp +portmon rss thinkpad truetype vim-syntax wifi X"
+IUSE="alsa apcupsd audacious bmpx debug hddtemp imlib lua math moc mpd nano-syntax nvidia +portmon rss thinkpad truetype vim-syntax wifi X"
+# currently removed openmp
DEPEND_COMMON="
X? (
@@ -29,10 +30,10 @@ DEPEND_COMMON="
bmpx? ( media-sound/bmpx >=sys-apps/dbus-0.35 )
portmon? ( dev-libs/glib )
lua? ( >=dev-lang/lua-5.1 )
- openmp? ( >=sys-devel/gcc-4.3[openmp] )
rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib )
wifi? ( net-wireless/wireless-tools )
"
+# openmp? ( >=sys-devel/gcc-4.3[openmp] )
RDEPEND="
${DEPEND_COMMON}
apcupsd? ( sys-power/apcupsd )
@@ -75,10 +76,10 @@ src_configure() {
$(use_enable moc) \
$(use_enable mpd) \
$(use_enable nvidia) \
- $(use_enable openmp) \
$(use_enable rss) \
$(use_enable wifi wlan) \
$(use_enable portmon)
+# $(use_enable openmp) \
}
src_install() {
diff --git a/app-admin/conky/conky-1.7.1.1.ebuild b/app-admin/conky/conky-1.7.2_rc2.ebuild
index 1fa941ffa871..90770ad1d8d2 100644
--- a/app-admin/conky/conky-1.7.1.1.ebuild
+++ b/app-admin/conky/conky-1.7.2_rc2.ebuild
@@ -1,36 +1,42 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.1.1.ebuild,v 1.3 2009/07/11 18:36:26 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.2_rc2.ebuild,v 1.1 2009/07/30 20:50:37 billie Exp $
EAPI="2"
+inherit eutils
+
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="http://conky.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3 BSD LGPL-2.1 MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa apcupsd audacious bmpx debug hddtemp imlib lua math moc mpd nano-syntax nvidia openmp +portmon rss thinkpad truetype vim-syntax wifi X"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa apcupsd audacious debug hddtemp imlib iostats lua lua-cairo lua-imlib math moc mpd nano-syntax nvidia +portmon rss thinkpad truetype vim-syntax weather-metar weather-xoap wifi X"
+# currently removed openmp
DEPEND_COMMON="
X? (
+ imlib? ( media-libs/imlib2 )
+ lua-cairo? ( >=dev-lang/toluapp-1.0.93 x11-libs/cairo[X] )
+ lua-imlib? ( >=dev-lang/toluapp-1.0.93 media-libs/imlib2 )
+ nvidia? ( media-video/nvidia-settings )
+ truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
x11-libs/libX11
x11-libs/libXdamage
x11-libs/libXext
- truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
- imlib? ( media-libs/imlib2 )
- nvidia? ( media-video/nvidia-settings )
)
alsa? ( media-libs/alsa-lib )
audacious? ( >=media-sound/audacious-1.5 )
- bmpx? ( media-sound/bmpx >=sys-apps/dbus-0.35 )
portmon? ( dev-libs/glib )
lua? ( >=dev-lang/lua-5.1 )
- openmp? ( >=sys-devel/gcc-4.3[openmp] )
rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib )
wifi? ( net-wireless/wireless-tools )
+ weather-metar? ( net-misc/curl )
+ weather-xoap? ( dev-libs/libxml2 net-misc/curl )
"
+# openmp? ( >=sys-devel/gcc-4.3[openmp] )
RDEPEND="
${DEPEND_COMMON}
apcupsd? ( sys-power/apcupsd )
@@ -44,10 +50,6 @@ DEPEND="
dev-util/pkgconfig
"
-src_prepare() {
- cp "${FILESDIR}"/conky_no_x11.conf data/
-}
-
src_configure() {
local myconf
if use X; then
@@ -62,20 +64,24 @@ src_configure() {
$(use_enable alsa) \
$(use_enable apcupsd) \
$(use_enable audacious) \
- $(use_enable bmpx) \
$(use_enable debug) \
$(use_enable hddtemp) \
$(use_enable imlib imlib2) \
+ $(use_enable iostats) \
$(use_enable lua) \
+ $(use_enable lua-cairo) \
+ $(use_enable lua-imlib lua-imlib2) \
$(use_enable thinkpad ibm) \
$(use_enable math) \
$(use_enable moc) \
$(use_enable mpd) \
$(use_enable nvidia) \
- $(use_enable openmp) \
+ $(use_enable portmon) \
$(use_enable rss) \
- $(use_enable wifi wlan) \
- $(use_enable portmon)
+ $(use_enable weather-metar) \
+ $(use_enable weather-xoap) \
+ $(use_enable wifi wlan)
+# $(use_enable openmp) \
}
src_install() {
diff --git a/app-admin/conky/metadata.xml b/app-admin/conky/metadata.xml
index 8f1d82986a91..1a56115987ba 100644
--- a/app-admin/conky/metadata.xml
+++ b/app-admin/conky/metadata.xml
@@ -25,6 +25,10 @@
<flag name='audacious'>enable monitoring of music played by <pkg>media-sound/audacious</pkg></flag>
<flag name='bmpx'>enable monitoring of music played by <pkg>media-sound/bmpx</pkg></flag>
<flag name='ipv6'>disable support for tcp (ip4) port monitoring</flag>
+ <flag name='iostats'>enable support for per-task I/O statistics</flag>
+ <flag name='lua'>enable if you want Lua scripting support</flag>
+ <flag name='lua-cairo'>enable if you want Lua Cairo bindings for Conky (also anables lua support)</flag>
+ <flag name='lua-imlib'>enable if you want Lua Imlib2 bindings for Conky (also enables lua and imlib support)</flag>
<flag name='math'>enable support for glibc's libm math library</flag>
<flag name='moc'>enable monitoring of music played by <pkg>media-sound/moc</pkg></flag>
<flag name='mpd'>enable monitoring of music controlled by <pkg>media-sound/mpd</pkg></flag>
@@ -33,5 +37,7 @@
<flag name='portmon'>enable support for tcp (ip4) port monitoring</flag>
<flag name='smapi'>enable support for smapi</flag>
<flag name='thinkpad'>enable support for IBM/Lenovo notebooks</flag>
+ <flag name='weather-metar'>enable support for metar weather service</flag>
+ <flag name='weather-xoap'>enable support for metar and xoap weather service</flag>
</use>
</pkgmetadata>