summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-26 00:42:04 +0000
committerChuck Short <zul@gentoo.org>2004-04-26 00:42:04 +0000
commita3fb0727d3d305acb550d4ed9abf83d29e48e486 (patch)
treeee6275b35f0231b2f7d146e8290c46d55c22ebb5 /app-admin/bacula
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-a3fb0727d3d305acb550d4ed9abf83d29e48e486.tar.gz
gentoo-2-a3fb0727d3d305acb550d4ed9abf83d29e48e486.tar.bz2
gentoo-2-a3fb0727d3d305acb550d4ed9abf83d29e48e486.zip
Version bump, closes #48969.
Diffstat (limited to 'app-admin/bacula')
-rw-r--r--app-admin/bacula/ChangeLog7
-rw-r--r--app-admin/bacula/Manifest2
-rw-r--r--app-admin/bacula/bacula-1.34.1.ebuild144
-rw-r--r--app-admin/bacula/files/digest-bacula-1.34.11
4 files changed, 153 insertions, 1 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
index 76ccd8dfc403..f04637e298df 100644
--- a/app-admin/bacula/ChangeLog
+++ b/app-admin/bacula/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/bacula
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.25 2004/04/26 00:34:10 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.26 2004/04/26 00:42:03 zul Exp $
+
+*bacula-1.34.1 (26 Apr 2004)
+
+ 26 Apr 2004; Chuck Short <zul@gentoo.org> bacula-1.34.1.ebuild:
+ Version bump, closes #48969.
26 Apr 2004; Chuck Short <zul@gentoo.org> bacula-1.34.0.ebuild:
Removed 1.34.0 becuase of race condition.
diff --git a/app-admin/bacula/Manifest b/app-admin/bacula/Manifest
index 68c378236cf2..28b5bd7bfb4d 100644
--- a/app-admin/bacula/Manifest
+++ b/app-admin/bacula/Manifest
@@ -1,3 +1,4 @@
+MD5 070eeb9fd2ef19944f9001bdef5f99f5 bacula-1.34.1.ebuild 3673
MD5 44a42713d947389c5e6f8593da166466 bacula-1.31.ebuild 3160
MD5 7d8026ac27aab1258edb0554f0eb5033 bacula-1.29.ebuild 3294
MD5 997fcf3c7fc219928109b372d3aaaa67 bacula-1.32f.ebuild 3917
@@ -9,5 +10,6 @@ MD5 68cdbb97c1064de4654b8db6160442ca files/digest-bacula-1.32f 268
MD5 6bd8611e451dde617342c14501fc36ba files/digest-bacula-1.29 64
MD5 9f8b17bb0e989cc4959debd22ad56aef files/digest-bacula-1.31 65
MD5 6c389eb1976a8e1131b6af4bdde9b6f3 files/bacula-init 1925
+MD5 f444bcaac48e16af2fd6fb2e247bf8b6 files/digest-bacula-1.34.1 66
MD5 13dd37747df7f32ec471e6bdf7eadec2 files/1.32f/1.32f-2-eom-nextvol.patch 9992
MD5 aba3c0108a7b301c99c8aa4f59a04081 files/1.32f/1.32f-1-weekofmonth.patch 1879
diff --git a/app-admin/bacula/bacula-1.34.1.ebuild b/app-admin/bacula/bacula-1.34.1.ebuild
new file mode 100644
index 000000000000..d71a6d857d9a
--- /dev/null
+++ b/app-admin/bacula/bacula-1.34.1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.34.1.ebuild,v 1.1 2004/04/26 00:42:04 zul Exp $
+
+DESCRIPTION="featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+SRC_URI="mirror://sourceforge/bacula/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="readline tcpd ssl gnome mysql sqlite X static postgres"
+
+#theres a local sqlite use flag. use it -OR- mysql, not both.
+#mysql is the reccomended choice ...
+DEPEND="sys-libs/libtermcap-compat
+ >=sys-libs/zlib-1.1.4
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ gnome? ( gnome-base/gnome-libs )
+ sqlite? ( >=dev-db/sqlite-2.7 )
+ mysql? ( >=dev-db/mysql-3.23 )
+ X? ( virtual/x11 )
+ virtual/mta
+ dev-libs/gmp"
+RDEPEND="${DEPEND}
+ sys-apps/mtx
+ app-arch/mt-st"
+
+src_compile() {
+ local myconf=""
+
+ #define this to skip building the other daemons ...
+ [ -n "$BUILD_CLIENT_ONLY" ] \
+ && myconf="${myconf} --enable-client-only"
+
+ myconf="
+ `use_enable readline`
+ `use_enable gnome`
+ `use_enable tcpd`
+ `use_enable X x`
+ "
+ #not ./configure'able
+ #`use_enable ssl`
+
+ # mysql is the reccomended choice ...
+ if use mysql
+ then
+ myconf="${myconf} --with-mysql=/usr"
+ elif use sqlite
+ then
+ myconf="${myconf} --with-sqlite=/usr/include"
+ elif use sqlite && use mysql
+ then
+ myconf="${myconf/--with-sqlite/}"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lib/bacula \
+ --with-working-dir=/var/lib/bacula \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+
+ if use static
+ then
+ cd ${S}/src/filed
+ make static-baula-fd
+ cd ${S}/src/console
+ make static-console
+ cd ${S}/src/dird
+ make static-bacula-dir
+ if use gnome
+ then
+ cd ${S}/src/gnome-console
+ fi
+ make static-gnome-console
+ cd ${S}/src/stored
+ make static-bacula-sd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use static
+ then
+ cd ${S}/src/filed
+ cp static-bacula-fd ${D}/usr/sbin/bacula-fd
+ cd ${S}/src/console
+ cp static-console ${D}/usr/sbin/console
+ cd ${S}/src/dird
+ cp static-bacula-dir ${D}/usr/sbin/bacula-dir
+ if use gnome
+ then
+ cd ${S}/src/gnome-console
+ cp static-gnome-console ${D}/usr/sbin/gnome-console
+ fi
+ cd ${S}/src/storge
+ cp static-bacula-sd ${D}/usr/sbin/bacula-sd
+ fi
+
+ rm -rf ${D}/var #empty dir
+
+ for a in ${S}/{ABOUT-NLS,COPYING,Changelog,CheckList,INSTALL \
+ README,ReleaseNotes,kernstodo,doc/bacula.pdf}
+ do
+ dodoc $a
+ done
+
+ cp -a ${S}/examples ${D}/usr/share/doc/${PF}
+ chown -R root:root ${D}/usr/share/doc/${PF} #hrmph :\
+ dohtml -r ${S}/doc/html-manual doc/home-page
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bacula-init bacula
+}
+
+pkg_postinst() {
+ # empty dir ...
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/bacula
+ einfo
+ einfo "If this is a new install and you plan to use mysql for your"
+ einfo "catalog database, then you should now create it by doing"
+ einfo "these commands:"
+ einfo " sh /etc/bacula/grant_mysql_privileges"
+ einfo " sh /etc/bacula/create_mysql_database"
+ einfo " sh /etc/bacula/make_mysql_tables"
+ einfo
+ einfo "Then setup your configuration files in /etc/bacula and"
+ einfo "start the daemons:"
+ einfo " /etc/init.d/bacula start"
+ einfo
+ einfo "If upgrading from version 1.30 or below, please note that"
+ einfo "the database format has changed. Please read the"
+ einfo "release notes for how to upgrade your database!!!"
+ einfo
+}
diff --git a/app-admin/bacula/files/digest-bacula-1.34.1 b/app-admin/bacula/files/digest-bacula-1.34.1
new file mode 100644
index 000000000000..4cdfe99f0082
--- /dev/null
+++ b/app-admin/bacula/files/digest-bacula-1.34.1
@@ -0,0 +1 @@
+MD5 d78fa49fad4ac1d369f97910084279f9 bacula-1.34.1.tar.gz 4413536