summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 15:08:26 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 15:08:26 +0000
commitc4b61df6b57b4263f100b53fb2296efb8b0064e5 (patch)
tree18881a2c7bf4d4ae4513a65f5688602e2622850b /app-accessibility
parentAdd another pathological use flag function, useno (inversion of use) (diff)
downloadgentoo-2-c4b61df6b57b4263f100b53fb2296efb8b0064e5.tar.gz
gentoo-2-c4b61df6b57b4263f100b53fb2296efb8b0064e5.tar.bz2
gentoo-2-c4b61df6b57b4263f100b53fb2296efb8b0064e5.zip
Version bump for Gnome 3.10
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog8
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.10.2.ebuild50
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild4
3 files changed, 59 insertions, 3 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index a283da7820f6..7cfccb367e1b 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.47 2013/12/24 12:20:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.48 2013/12/24 15:08:26 pacho Exp $
+
+*at-spi2-core-2.10.2 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org> +at-spi2-core-2.10.2.ebuild,
+ at-spi2-core-2.8.0.ebuild:
+ Version bump for Gnome 3.10
24 Dec 2013; Pacho Ramos <pacho@gentoo.org> -at-spi2-core-2.2.3.ebuild,
-at-spi2-core-2.4.2.ebuild, at-spi2-core-2.8.0.ebuild:
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.10.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.10.2.ebuild
new file mode 100644
index 000000000000..651c36731109
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.10.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.10.2.ebuild,v 1.1 2013/12/24 15:08:26 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1
+ x11-libs/libSM
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ gnome2_src_configure \
+ --disable-xevie \
+ $(use_enable introspection) \
+ $(use_enable X x11)
+}
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild
index 2e7381d3f7d5..419775baa4c6 100644
--- a/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild,v 1.6 2013/12/24 12:20:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.8.0.ebuild,v 1.7 2013/12/24 15:08:26 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -45,4 +45,4 @@ src_configure() {
gnome2_src_configure \
--disable-xevie \
$(use_enable introspection)
-} \ No newline at end of file
+}