summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-07 18:35:50 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-07 18:35:50 +0000
commita149bd4fd07975cadb83bcfe95f253d3fc6c60fc (patch)
tree39f587f2c608a7b5eb37fcfc853d5484c5b68bf8 /app-accessibility
parentBackport systemd unit files for faster stabilization (#506792 by Paolo Pedroni) (diff)
downloadgentoo-2-a149bd4fd07975cadb83bcfe95f253d3fc6c60fc.tar.gz
gentoo-2-a149bd4fd07975cadb83bcfe95f253d3fc6c60fc.tar.bz2
gentoo-2-a149bd4fd07975cadb83bcfe95f253d3fc6c60fc.zip
Do not use `pkg-config` all the time.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog6
-rw-r--r--app-accessibility/brltty/brltty-4.5-r3.ebuild10
-rw-r--r--app-accessibility/brltty/brltty-5.0-r2.ebuild10
3 files changed, 21 insertions, 5 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index 8f05ce39e5d7..8a916a6dd65a 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.148 2014/02/22 20:04:25 teiresias Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.149 2014/04/07 18:35:50 vapier Exp $
+
+ 07 Apr 2014; Mike Frysinger <vapier@gentoo.org> brltty-4.5-r3.ebuild,
+ brltty-5.0-r2.ebuild:
+ Do not use `pkg-config` all the time.
22 Feb 2014; Christopher Brannon <teiresias@gentoo.org> -brltty-4.2.ebuild,
-brltty-4.2-r1.ebuild, -files/brltty-4.2-fix-a2.patch,
diff --git a/app-accessibility/brltty/brltty-4.5-r3.ebuild b/app-accessibility/brltty/brltty-4.5-r3.ebuild
index b43bc2ca3f88..872fe0450b08 100644
--- a/app-accessibility/brltty/brltty-4.5-r3.ebuild
+++ b/app-accessibility/brltty/brltty-4.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.5-r3.ebuild,v 1.8 2014/01/19 10:17:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.5-r3.ebuild,v 1.9 2014/04/07 18:35:50 vapier Exp $
EAPI=5
@@ -50,6 +50,12 @@ src_prepare() {
java-pkg-opt-2_src_prepare
+ # The code runs `pkg-config` directly instead of locating a suitable
+ # pkg-config wrapper (or respecting $PKG_CONFIG).
+ sed -i \
+ -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
+ aclocal.m4 configure.ac || die
+
# We run eautoconf instead of using eautoreconf because brltty uses
# a custom build system that uses autoconf without the rest of the
# autotools.
@@ -57,7 +63,7 @@ src_prepare() {
}
src_configure() {
- tc-export AR LD
+ tc-export AR LD PKG_CONFIG
# override prefix in order to install into /
# braille terminal needs to be available as soon in the boot process as
# possible
diff --git a/app-accessibility/brltty/brltty-5.0-r2.ebuild b/app-accessibility/brltty/brltty-5.0-r2.ebuild
index 93b9df79ea1e..618321ee2a67 100644
--- a/app-accessibility/brltty/brltty-5.0-r2.ebuild
+++ b/app-accessibility/brltty/brltty-5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-5.0-r2.ebuild,v 1.1 2014/02/22 19:52:12 teiresias Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-5.0-r2.ebuild,v 1.2 2014/04/07 18:35:50 vapier Exp $
EAPI=5
@@ -48,6 +48,12 @@ src_prepare() {
java-pkg-opt-2_src_prepare
+ # The code runs `pkg-config` directly instead of locating a suitable
+ # pkg-config wrapper (or respecting $PKG_CONFIG).
+ sed -i \
+ -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
+ aclocal.m4 configure.ac || die
+
# We run eautoconf instead of using eautoreconf because brltty uses
# a custom build system that uses autoconf without the rest of the
# autotools.
@@ -55,7 +61,7 @@ src_prepare() {
}
src_configure() {
- tc-export AR LD
+ tc-export AR LD PKG_CONFIG
# override prefix in order to install into /
# braille terminal needs to be available as soon in the boot process as
# possible