summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:25:40 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:25:40 +0000
commit58807fbac4641bab989a3e9c2ed98953d02523f4 (patch)
tree3538b49dc66c6f0fa14f93238fb8f58452541d20 /app-accessibility
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-58807fbac4641bab989a3e9c2ed98953d02523f4.tar.gz
gentoo-2-58807fbac4641bab989a3e9c2ed98953d02523f4.tar.bz2
gentoo-2-58807fbac4641bab989a3e9c2ed98953d02523f4.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/ChangeLog8
-rw-r--r--app-accessibility/accerciser/accerciser-3.8.0.ebuild68
2 files changed, 74 insertions, 2 deletions
diff --git a/app-accessibility/accerciser/ChangeLog b/app-accessibility/accerciser/ChangeLog
index 20cafd4a32c5..ab0a35e1f7af 100644
--- a/app-accessibility/accerciser/ChangeLog
+++ b/app-accessibility/accerciser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/accerciser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.30 2013/03/05 22:21:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.31 2013/03/28 16:25:40 pacho Exp $
+
+*accerciser-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +accerciser-3.8.0.ebuild:
+ Version bump for Gnome 3.8
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -accerciser-3.4.1.ebuild,
accerciser-3.6.2-r1.ebuild:
@@ -123,4 +128,3 @@
02 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+accerciser-1.6.1.ebuild, +metadata.xml:
New ebuild for GNOME 2.26.
-
diff --git a/app-accessibility/accerciser/accerciser-3.8.0.ebuild b/app-accessibility/accerciser/accerciser-3.8.0.ebuild
new file mode 100644
index 000000000000..cab8536e8916
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.8.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-3.8.0.ebuild,v 1.1 2013/03/28 16:25:40 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python3_2 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ }
+ python_foreach_impl run_in_build_dir installing
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}