summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-11-17 17:45:56 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-11-17 17:45:56 +0000
commit13f171ca7ccfe762d68977a83ae3b5bf71afcb1e (patch)
tree3fe4d3e34ad6dad4679191fd2cbb2c8bd153f36a /app-accessibility
parentVersion bump. (diff)
downloadgentoo-2-13f171ca7ccfe762d68977a83ae3b5bf71afcb1e.tar.gz
gentoo-2-13f171ca7ccfe762d68977a83ae3b5bf71afcb1e.tar.bz2
gentoo-2-13f171ca7ccfe762d68977a83ae3b5bf71afcb1e.zip
Version bump. Closes bug #344991
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/sphinx3/ChangeLog10
-rw-r--r--app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch34
-rw-r--r--app-accessibility/sphinx3/sphinx3-0.8.ebuild70
3 files changed, 112 insertions, 2 deletions
diff --git a/app-accessibility/sphinx3/ChangeLog b/app-accessibility/sphinx3/ChangeLog
index 20a824c5ea09..62090c55be5a 100644
--- a/app-accessibility/sphinx3/ChangeLog
+++ b/app-accessibility/sphinx3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/sphinx3
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.4 2009/04/01 18:05:03 williamh Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.5 2011/11/17 17:45:56 neurogeek Exp $
+
+*sphinx3-0.8 (17 Nov 2011)
+
+ 17 Nov 2011; Jesus Rivero <neurogeek@gentoo.org> +sphinx3-0.8.ebuild,
+ +files/sphinx3-0.8_heap_fix.patch:
+ Version bump. Closes bug #344991
01 Apr 2009; William Hubbs <williamh@gentoo.org> sphinx3-0.6.3.ebuild:
Stable on x86.
diff --git a/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
new file mode 100644
index 000000000000..b7b71d974413
--- /dev/null
+++ b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
@@ -0,0 +1,34 @@
+diff -uNr sphinx3-0.8.orig/python/setup.py sphinx3-0.8/python/setup.py
+--- sphinx3-0.8.orig/python/setup.py 2008-12-31 23:20:08.000000000 -0500
++++ sphinx3-0.8/python/setup.py 2011-11-17 09:46:57.000000000 -0500
+@@ -8,15 +8,10 @@
+ define_macros = []
+
+ module = Extension('_sphinx3',
+- include_dirs = ['../../sphinxbase/include',
+- '../include',
+- '/usr/local/include/sphinxbase/',
+- '/usr/local/include/sphinx3',
+- ],
++ include_dirs = ['../include',
++ '@GENTOO_PORTAGE_EPREFIX@/usr/include/sphinxbase'],
+ define_macros = define_macros,
+- library_dirs = ['../../sphinxbase/src/libsphinxbase/.libs',
+- '../src/libs3decoder/.libs',
+- '../../sphinxbase/lib/debug',
++ library_dirs = ['../src/libs3decoder/.libs',
+ '../lib/debug',
+ ],
+ libraries = ['sphinxbase', 's3decoder'],
+diff -uNr sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c sphinx3-0.8/src/libs3decoder/libsearch/vithist.c
+--- sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c 2008-12-31 13:27:56.000000000 -0500
++++ sphinx3-0.8/src/libs3decoder/libsearch/vithist.c 2011-11-17 09:46:24.000000000 -0500
+@@ -647,7 +647,7 @@
+ {
+ int32 se, fe, filler_done, th;
+ vithist_entry_t *ve;
+- heap_t h;
++ heap_t *h;
+ s3wid_t *wid;
+ int32 i;
+
diff --git a/app-accessibility/sphinx3/sphinx3-0.8.ebuild b/app-accessibility/sphinx3/sphinx3-0.8.ebuild
new file mode 100644
index 000000000000..08fa4df81c44
--- /dev/null
+++ b/app-accessibility/sphinx3/sphinx3-0.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8.ebuild,v 1.1 2011/11/17 17:45:56 neurogeek Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools-utils prefix python
+
+DESCRIPTION="CMU Speech Recognition engine"
+HOMEPAGE="http://cmusphinx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc python static-libs"
+
+DEPEND=">=app-accessibility/sphinxbase-0.7[static-libs?,python?]"
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_heap_fix.patch"
+ eprefixify 'python/setup.py'
+}
+
+src_configure() {
+ econf \
+ $( use_enable static-libs static )
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ "$(PYTHON)" setup.py build
+ }
+
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ cd doc
+ dohtml -r -x CVS s3* s3 *.html
+ fi
+
+ if use python; then
+
+ installing() {
+ "$(PYTHON)" setup.py install \
+ --install-lib="${D}/$(python_get_sitedir)"
+ }
+
+ python_execute_function -s --source-dir python installing
+ fi
+
+ remove_libtool_files
+}