summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-06-21 16:12:36 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-06-21 16:12:36 +0000
commit6b83cce060ba9839cb5abfab2a6be4648a99bb5a (patch)
treee9b7f50d5b0c2d2499fcf1ee658ed12d2cbb186a /app-accessibility/eflite/eflite-0.4.1.ebuild
parentMask ncurses-5.7-r1 as it breaks Solaris and Darwin, and probably much more (diff)
downloadgentoo-2-6b83cce060ba9839cb5abfab2a6be4648a99bb5a.tar.gz
gentoo-2-6b83cce060ba9839cb5abfab2a6be4648a99bb5a.tar.bz2
gentoo-2-6b83cce060ba9839cb5abfab2a6be4648a99bb5a.zip
version bump for bug #274247.
Also removed an old version and fixed repoman errors. (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/eflite/eflite-0.4.1.ebuild')
-rw-r--r--app-accessibility/eflite/eflite-0.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-accessibility/eflite/eflite-0.4.1.ebuild b/app-accessibility/eflite/eflite-0.4.1.ebuild
new file mode 100644
index 000000000000..b07a3ef43b5b
--- /dev/null
+++ b/app-accessibility/eflite/eflite-0.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/eflite-0.4.1.ebuild,v 1.1 2009/06/21 16:12:36 williamh Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A speech server that allows emacspeak and other screen readers to interact with festival lite."
+HOMEPAGE="http://eflite.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-accessibility/flite-1.2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' *
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog README INSTALL eflite_test.txt
+
+ insinto /etc/eflite
+ doins "${FILESDIR}"/es.conf
+
+ newinitd "${FILESDIR}"/eflite.rc eflite
+}
+
+pkg_postinst() {
+ enewgroup speech
+}